WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#4639 closed defect (bug) (fixed)

action admin_print_scripts- isnt fired for plugins which reside in a subdir.

Reported by: DD32 Owned by:
Milestone: 2.3 Priority: normal
Severity: normal Version: 2.3
Component: Administration Keywords: admin_print_scripts get_plugin_page_hook has-patch
Focuses: Cc:

Description

admin-header.php:

if ( isset($page_hook) )
	do_action('admin_print_scripts-' . $page_hook);
else if ( isset($plugin_page) )
	do_action('admin_print_scripts-' . $plugin_page);

For plugins which reside in a subdirectory (ie. /wp-content/plugins/plugin_name/plugin.php), the admin_print_scripts- action doesnt fire, The problem is that $page_hook is a 0 character string, however IS set.

Theres 2 options i can see, correcting the function which assigns to $page_hook, or testing for isset() && ! empty()

Attached is a patch to modify get_plugin_page_hook() to return null insead of , this causes $page_hook to "not be set" which in turn, causes the print scripts hook to correctly run.

Attachments (2)

4639.get_plugin_page_hook.patch (466 bytes) - added by DD32 8 years ago.
get_plugin_page_hook fix
4639.get_plugin_page_hook.diff (466 bytes) - added by DD32 8 years ago.
get_plugin_page_hook fix as diff instead

Download all attachments as: .zip

Change History (5)

@DD328 years ago

get_plugin_page_hook fix

@DD328 years ago

get_plugin_page_hook fix as diff instead

comment:1 @DD328 years ago

  • Keywords admin_print_scripts get_plugin_page_hook added

Apologies for the 2 different format patches/diffs, the HTML viewer didnt work for the .patch file, so i thought it only accepted .diff, but that isnt working either.

comment:2 @Nazgul8 years ago

  • Keywords has-patch added
  • Milestone set to 2.3 (trunk)

comment:3 @ryan8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5803]) Return hook as null instead of empty string. Props DD32. fixes #4639

Note: See TracTickets for help on using tickets.