WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

#46391 closed defect (bug) (duplicate)

function is_email returns true on ... or .@ within the e-mail-address

Reported by: RudolfFiedler Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords: has-patch
Focuses: Cc:
PR Number:

Description

Hi,
the correct e-mail-address-syntax don't allow points (.) exactly before the @, and don't allow more than one point back to back.
2 examples:
The e-mail r.fiedler.@… is wrong, but is_email() returns true
the e-mail r..fiedler@… is wrong, but is_email() returns true

Attachments (2)

46391.diff (1021 bytes) - added by achyuthajoy 8 months ago.
Updated is_email local part regex according to RFC 5952
46391.2.diff (1021 bytes) - added by achyuthajoy 8 months ago.
Updated is_email local part regex according to RFC 5952

Download all attachments as: .zip

Change History (4)

@achyuthajoy
8 months ago

Updated is_email local part regex according to RFC 5952

@achyuthajoy
8 months ago

Updated is_email local part regex according to RFC 5952

#1 in reply to: ↑ description @achyuthajoy
8 months ago

  • Keywords has-patch added; needs-patch removed

Replying to RudolfFiedler:

Hi,
the correct e-mail-address-syntax don't allow points (.) exactly before the @, and don't allow more than one point back to back.
2 examples:
The e-mail r.fiedler.@… is wrong, but is_email() returns true
the e-mail r..fiedler@… is wrong, but is_email() returns true

#2 @ocean90
8 months ago

  • Component changed from General to Formatting
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.1 deleted

Duplicate of #17491.

Note: See TracTickets for help on using tickets.