WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 6 months ago

#46398 closed defect (bug) (invalid)

"Email me whenever" in options-discussion.php is wrong

Reported by: qdinar Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Comments Keywords:
Focuses: Cc:
PR Number:

Description

i write 2 related things in one bug.

problem 1:

at least, in multisite mode, that ("Email me whenever") is wrong.

i see, that emails are sent not to site's administration email, but to post author/poster's email.

if there is another user posting in the site, emails about comments to his posts are sent only to him, not sent to me (current user).

problem 2:

also description for Email Address in options-general.php should be edited. that is:

This address is used for admin purposes. If you change this we will send you an email at your new address to confirm it. The new address will not become active until confirmed.

this is not good because emails for comment moderation is of admin purpose, but they are not sent to this email, as i said above.

Change History (4)

#1 @qdinar
9 months ago

it is this way:

Email me whenever
[] Anyone posts a comment
[] A comment is held for moderation

#2 @earnjam
6 months ago

  • Keywords reporter-feedback added

Emails for comment moderation go to both the author of the post, and the admin email for the site, which is controlled under /wp-admin/options-general.php.

I've tested this on both a subdomain and subdirectory multisite installation and it worked correctly in each instance.

Do you have any plugins which might be interfering with admin email notifications? Can you confirm the issue you've described exists on a site with the default theme and no plugins active?

#3 @qdinar
6 months ago

i think my bug report was not valid. i have investigated the case that was in march 2 and i see that i made test comments to a post made by another administrator, other than "admin". emails about test comments has come only to the other admin's mailbox. maybe, in case of 2 admins, this behaviour of wordpress is intentional. and i checked and see that only admin is superadmin, but the other admin is not. but they both were administrators on that site. some of test comments were sent to another admin's site, where only he is administrator and author, and only he got emails, but if superadmin enters this site's dashboard, he still sees "email *me* whenever ...".

Last edited 6 months ago by qdinar (previous) (diff)

#4 @earnjam
6 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.