WordPress.org

Make WordPress Core

Opened 8 months ago

Last modified 3 months ago

#46403 new defect (bug)

Text without line breaks after copying in the visual editor

Reported by: forumaad Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.1
Component: Editor Keywords: needs-patch has-screenshots reporter-feedback
Focuses: Cc:
PR Number:

Description

If you copy the text (ctrl+c) in the visual editor, it is copied text without line breaks.

Attachments (2)

1.jpg (178.1 KB) - added by forumaad 8 months ago.
2.jpg (181.3 KB) - added by forumaad 8 months ago.

Download all attachments as: .zip

Change History (6)

@forumaad
8 months ago

@forumaad
8 months ago

#1 @mcmwebsol
7 months ago

I confirmed that this is happening in 5.2 beta as well in Notepad. Oddly copying to Libre Office Writer works fine.

#2 @forumaad
6 months ago

This bug is very disturbing.
appeared in version 5.1
And still not fixed
Please fix it.
;_(

#3 @forumaad
6 months ago

  • Keywords has-screenshots added

#4 @azaozz
3 months ago

  • Keywords reporter-feedback added

@forumaad welcome to trac and thanks for the bug report.

Tried with several text editors including Notepad on Win10 and cannot reproduce. May have something to do with charset/locale in the browser being different that in the OS? Perhaps one is UTF-8 and the other is KOI8-R or similar.

Could you try pasting in another plain text editor, or in a textarea in the same browser. Even just switch to the Text tab, delete the content and paste. Also see what is the locale setting in the browser and in Windows.

Note: See TracTickets for help on using tickets.