WordPress.org

Make WordPress Core

Opened 9 months ago

Closed 9 months ago

#46406 closed defect (bug) (invalid)

Creating new multi site not updating wp_domain_mapping table

Reported by: milonic Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Networks and Sites Keywords:
Focuses: multisite Cc:
PR Number:

Description

I just had problems with cookies and logging into to a new multi site blog I created. Error was related to Cookies not being set on the browser.

After some debugging, I found that the problem was caused by a missing entry in the domain_mapping table. Once I added a manual entry the new blog worked perfectly.

I then decided to see what the problem was and after scanning the code I cannot find anything that adds or updates the domain_mapping table. The only code I can see that references domain_mapping is a SELECT statement inside sunrise.php

Looks like there's some code required to update the domain_mapping table that used to be in the plugin but isn't in the latest WordPress release.

Change History (1)

#1 @earnjam
9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @milonic and welcome to WordPress Trac!

wp_domain_mapping is not a table added or managed by WordPress core. It is typically added by one of the domain mapping plugins. Since you have that and a sunrise.php file, this sounds like an issue outside of core. For support questions you should post on the Support Forums.

I’m going to close this as invalid, but if you have any additional information that would indicate some kind of backward compatibility break, please feel free to share and reopen the ticket.

Note: See TracTickets for help on using tickets.