WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 5 months ago

#46409 closed enhancement (duplicate)

Wrong Permisson for wp-config.php

Reported by: boleynsu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords: has-patch
Focuses: Cc:

Description

wp-config.ph is chmoded to 0666 which should be 0660.

in /wp-admin/setup-config.php
chmod( $path_to_wp_config, 0666 );

BTW, it would be better to chmod wp-config-sample.php to 0660 in the whatever package since user sometimes copy and modify wp-config-sample.php to wp-config.php

Attachments (1)

46409.diff (571 bytes) - added by sebastienserre 6 months ago.

Download all attachments as: .zip

Change History (4)

#1 @sebastienserre
6 months ago

  • Keywords has-patch 2nd-opinion added

Hello @boleynsu and welcome to Trac!
I created a patch, let's & see ;-)

many thanks for your contribution

#2 @ocean90
6 months ago

  • Component changed from Administration to General
  • Keywords 2nd-opinion removed
  • Milestone Awaiting Review deleted
  • Severity changed from minor to normal
  • Version 5.1 deleted

Thanks for the report. We're already tracking this issue in #37264.

#3 @SergeyBiryukov
5 months ago

  • Component changed from General to Upgrade/Install
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #37264.

Note: See TracTickets for help on using tickets.