WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#46416 closed defect (bug) (duplicate)

Moving up the link next to the button when the button is focused/unfocused

Reported by: man4toman Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Administration Keywords: has-patch close
Focuses: administration Cc:

Description

After installing the plugin from Add Plugins -> Upload Plugin, the link next to the button goes up and down when the button is focused/unfocused.

Please see the attachment.

Attachments (6)

46416.patch (443 bytes) - added by man4toman 16 months ago.
The patch
01-default.png (29.3 KB) - added by man4toman 16 months ago.
Default
02-focus.png (29.3 KB) - added by man4toman 16 months ago.
When focusing
test.gif (4.1 MB) - added by man4toman 16 months ago.
Test result
test.mp4 (2.0 MB) - added by man4toman 16 months ago.
Test result
46416.1.diff (459 bytes) - added by ianbelanger 16 months ago.
Updated patch to cover IE and Edge

Change History (19)

@man4toman
16 months ago

The patch

@man4toman
16 months ago

Default

@man4toman
16 months ago

When focusing

#1 @desrosj
16 months ago

  • Keywords reporter-feedback close added

I am unable to reproduce this with a fresh install on WordPress 5.1. I think that a plugin that you have active may be causing this behavior.

Can you please test with no plugins active?

I am going to mark this a candidate for closing because it worksforme with a fresh install.

#2 @man4toman
16 months ago

Hi @desrosj
I'll test it with a fresh install and send the result here.

@man4toman
16 months ago

Test result

#3 @man4toman
16 months ago

@desrosj
I check it with fresh install of WordPress 5.1 without any plugin, but the problem still here.
Please look at the gif file.

@man4toman
16 months ago

Test result

#4 @man4toman
16 months ago

I attach the video of my test, it has better resolution.

#5 @ianbelanger
16 months ago

  • Keywords needs-patch added; has-patch needs-testing reporter-feedback close removed

This issue appears to be a Windows bug only. I tested it in Firefox, Chrome and IE, all of which display the bug, on focus. The proposed patch does fix the bug in FF and Chrome, but does not seem to fix it in IE. I will test some other solutions in IE so we can patch this.

Thanks for reporting @man4toman

#6 @man4toman
16 months ago

Your welcome @ianbelanger
I test my patch again, it seems it doesn't work on Microsoft Edge too.

@ianbelanger
16 months ago

Updated patch to cover IE and Edge

#7 @ianbelanger
16 months ago

  • Keywords has-patch needs-testing added; needs-patch removed

Patch 46416.1.diff changes vertical-align: initial; to vertical-align: inherit; in order to cover the bug in IE and Edge

#8 @man4toman
16 months ago

@ianbelanger
Works fine on FF and chrome too.

#9 @ianbelanger
16 months ago

  • Keywords needs-testing removed

Hi @man4toman, thanks for clarifying. Yes I should've mentioned that this solution should cover all supported browsers for Windows machines

#10 @desrosj
16 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to Future Release

Moving this to Future Release. I do not have a Windows machine. A committer with access to Windows should give this some final testing and review.

Marking commit based on the fact that the solution works and needs a final review.

#11 @ianbelanger
16 months ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #44836.

#12 @ianbelanger
16 months ago

  • Keywords close added; commit removed

I found that this a duplicate of an older ticket. The discussion should be continued there. Although I do believe that the solution we have on this ticket is better than what has been suggested on #44836. I am going to submit an updated patch on that ticket.

#13 @man4toman
16 months ago

Well done @ianbelanger

Note: See TracTickets for help on using tickets.