WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#46425 closed defect (bug) (worksforme)

Comment Form : Cookie Opt-In

Reported by: kartiks16 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Comments Keywords:
Focuses: Cc:

Description

Hello Team,

I activated the checkbox “Show comments cookies opt-in checkbox, allowing comment author cookies to be set” in the backend of my WordPress installation. Not surprisingly, a checkbox labeled “Save my name, email, and website in this browser for the next time I comment” appeared in all comment forms on my website.

To test this feature, I started an incognito session in Google Chrome and posted a comment. I did not check the checkbox. From my understanding, when the checkbox is unchecked, no cookies should be stored on the user’s computer. But WordPress did

https://i.imgur.com/NGIMATC.png

However, the actual field values (name, email) were not preserved. So on the surface, the checkbox does its job. But I think it would be better if no cookies were created in this case.

I could reproduce this behavior even in a clean installation of WordPress 5.1 with default settings.

Did I misunderstand the intention of this opt-in checkbox?

Change History (6)

#1 @garrett-eclipse
3 years ago

  • Keywords reporter-feedback added; needs-testing 2nd-opinion removed

Hi @kartiks16 I appreciate the report. Sadly I've been unable to reproduce this with a clean install of 5.1 using TwentyNineteen.

What theme do you have enabled btw? Are there any customizations to it? What language is your site set to? Do you have any plugins enabled?

You understood the intention of the checkbox correctly, but I'm unable to reproduce the issue sadly so will need some additional information.

Thanks

Last edited 3 years ago by garrett-eclipse (previous) (diff)

#2 @garrett-eclipse
2 years ago

  • Keywords close added

Hi @kartiks16, I just wanted to check and see if you'd had a chance to test this with the latest WordPress (now 5.2.2). If you are still running into the problem would love to hear more about your configuration. Going to mark for close as I haven't been able to reproduce, if you are still seeing those cookies am happy to investigate further. Cheers

#3 @kartiks16
2 years ago

  • Resolution set to maybelater
  • Status changed from new to closed

Hello @garrett-eclipse

Thank you for reviewing and investigating it. I did test this in the latest version i.e. 5.2.2 and it seems to be working fine.

So yes, we can mark this as closed. In case I am able to reproduce again with Fresh WP installation I will update you here.

Thank you for the help so far.

#4 @SergeyBiryukov
2 years ago

  • Keywords reporter-feedback close removed
  • Resolution changed from maybelater to worksforme

#5 @garrett-eclipse
2 years ago

Awesome @kartiks16 I appreciate you taking the time to report back there. That's great news, thanks for closing the thread.

#6 @desrosj
2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.