WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#46442 closed defect (bug) (invalid)

Visual Editors stopped working with WordPress v5.1

Reported by: burningthumb Owned by:
Milestone: Priority: normal
Severity: major Version: 5.1
Component: Editor Keywords:
Focuses: Cc:

Description

When I upgraded to WordPress v5.1 both the classic and gutenberg visual editors stopped working. In the classic editor I would get no buttons, a tinyMCE not found error in the browser console, and a blank edit area. In Gutenberg I would get a completely blank screen, there was also JS console errors for undefined symbols. In both cases I could click and drag to see the text was there but was white.

I was saved by the WP Downgrade plugin which I used to downgrade from v5.1 back to v5.0.3 where the visual editors are working again.

I worked on this for almost 3 days. Very, very, annoying.

As a test, I reinstalled v5.1 and the editors stop working, then I rolled back to v5.0.3 and they start working again. Its repeatable at will.

Change History (30)

#1 @burningthumb
17 months ago

My hosting company is Telus. I mention this because on godaddy.com I have upgraded to v5.1 with no problems so maybe its something specific to hosting companies / resources. I don't know. I raised a ticket with Telus and they were completely useless.

#2 @CarolKn
17 months ago

Same issue with a site on ATT hosting. A nearly exact copy of the site on A2 works fine, as do other WP 5.1 sites with same theme and plugins on A2, Siteground & Hostgator. I disabled all plugins, replaced all WordPress core files - to no avail. I am getting SyntaxError: "" string literal contains an unescaped line break in mce-view.min.js:1:5816, but replacing this file (or tinymce altogether) with a known good copy from 5.1 does not fix the problem. Text editor works fine; visual editor link doesn't work, and Gutenberg displays a white screen (view source has content.) Have installed Classic Editor plugin, but reinstalling, disabling, changing settings doesn't have an effect. I am reluctant to back out to 5.0.3 since this is a live site and the public display is not affected. Both the copy and live site are running php 7.1.

Last edited 17 months ago by CarolKn (previous) (diff)

#3 follow-up: @usmc1
17 months ago

I have been running a website on WordPress(then at v5.1) using the theme Esteem (v1.4.2) by Theme Grill using Firefox v66.0b13. Two weeks ago I started getting a white screen when I try to edit any page. I can’t think of any change that might have led to this (e.g. new plug-ins). Interestingly, the widget that allows a common block to be displayed on all pages was still editable.

I tried the following, none of which have worked:

  1. cleared my browser cache
  2. deactivated all plug-ins
  3. changed the theme to Twenty Nineteen
  4. reverted to Classic Editor
  5. used Internet Explorer and Edge as alternative browsers
  6. logged in via my mobile using Chrome
  7. called the host support but they cound't find any issues at their end

Health Checker didn't show up anything untoward.

I got someone to investigate and it appeared that my host put tracking pixel code in too many files – including one called tinymce.min.js. This meant that that broke, so he turned the tracking pixel off and after some fiddling (not sure what) it worked. It then stopped working again on my laptop that evening but by the next day WordPress had been upgraded to v5.1.1 and it’s back working.

#4 in reply to: ↑ 3 ; follow-up: @burningthumb
17 months ago

I just tried v5.1.1 and the problem is still there on my host. Can you provide more details or a contact at your hosting company as its not clear what you mean by they put tracking pixel code in too many files.

#5 @CarolKn
17 months ago

The problem still exists on my host with 5.1.1.

#6 in reply to: ↑ 4 ; follow-up: @usmc1
17 months ago

Replying to burningthumb:

I just tried v5.1.1 and the problem is still there on my host. Can you provide more details or a contact at your hosting company as its not clear what you mean by they put tracking pixel code in too many files.

There's an option on my host's front end which offers the option to switch off the pixel tracking. It was a friend that fixed the tinymce.min.js file not the host. I can't help beyond that, I'm afraid.

#7 in reply to: ↑ 6 ; follow-up: @burningthumb
17 months ago

Its odd since I replaced the tinymce.min.js file with known good copy from a working site on godaddy.com (and I also ran a diff on the tinymce.min.js on both sites and they are identical) so I know tinymce.min.js is good.

Also since Wordpress v5.0.3 is working, the problem started with the v5.1 update, and both v5.1 and v5.1.1 are not I still think, even if something the hosting company is doing is the cause (which surely it appears to be), something in the Wordpress core can be / should be changed to fix it by reverting to whatever v5.0.3 is doing.

Replying to usmc1:

Replying to burningthumb:

I just tried v5.1.1 and the problem is still there on my host. Can you provide more details or a contact at your hosting company as its not clear what you mean by they put tracking pixel code in too many files.

There's an option on my host's front end which offers the option to switch off the pixel tracking. It was a friend that fixed the tinymce.min.js file not the host. I can't help beyond that, I'm afraid.

#8 in reply to: ↑ 7 @CarolKn
17 months ago

Replying to burningthumb:

Its odd since I replaced the tinymce.min.js file with known good copy from a working site on godaddy.com (and I also ran a diff on the tinymce.min.js on both sites and they are identical) so I know tinymce.min.js is good.

Also since Wordpress v5.0.3 is working, the problem started with the v5.1 update, and both v5.1 and v5.1.1 are not I still think, even if something the hosting company is doing is the cause (which surely it appears to be), something in the Wordpress core can be / should be changed to fix it by reverting to whatever v5.0.3 is doing.

Replying to usmc1: Same experience. Unfortunately our client wants us to wait until 3/25 to try rolling back to 5.0.3, so we wait...

Replying to burningthumb:

I just tried v5.1.1 and the problem is still there on my host. Can you provide more details or a contact at your hosting company as its not clear what you mean by they put tracking pixel code in too many files.

There's an option on my host's front end which offers the option to switch off the pixel tracking. It was a friend that fixed the tinymce.min.js file not the host. I can't help beyond that, I'm afraid.

#9 follow-ups: @azaozz
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sounds like the hosting company is inserting/appending a string (tracking pixel) to the JS file? Ugh...

In any case, this doesn't seem to be an issue in core. Manipulating JS files is a big no-no! Please contact your host and open a thread on the support forum to track any progress.

#10 @burningthumb
17 months ago

So assuming this is the case, which seems reasonable, why is Wordpress v5.0.3 working but v5.1 is not? Would v5.0.3 not have the same problem if the hosting company, in this case Telus, was modifying the .js file? I need to be able to explain this to Telus support when I call them.

#11 in reply to: ↑ 9 @burningthumb
17 months ago

So I called Telus and they say they are not modifying the .js files.

azaozz:

Sounds like the hosting company is inserting/appending a string (tracking pixel) to the JS file? Ugh...

In any case, this doesn't seem to be an issue in core. Manipulating JS files is a big no-no! Please contact your host and open a thread on the support forum to track any progress.

#12 @burningthumb
17 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#13 in reply to: ↑ 9 @CarolKn
17 months ago

Replying to azaozz:

Sounds like the hosting company is inserting/appending a string (tracking pixel) to the JS file? Ugh...

In any case, this doesn't seem to be an issue in core. Manipulating JS files is a big no-no! Please contact your host and open a thread on the support forum to track any progress.

@azaozz is correct. I looked more closely inside one of the affected JS files and found "WiredMinds eMetrics tracking with Enterprise Edition V5.4". Google search returns your host Telus as one host that inserts pixel tracking code willy-nilly into files, including the middle of JS files.
http://www.dslreports.com/forum/r28249867-BC-Telus-Hosting-what-is-this-code-on-our-web-pages

Solution that worked for me was logging into ATT hosting, finding Analytics, poking around till I found Web Analytics | Advanced | Manage Pixel Code. Set to off, clear cache, hard refresh on admin / editor and it's fixed.

Several other folks out there having similar issues... Curious why this is a problem all the sudden with WP.

Last edited 17 months ago by CarolKn (previous) (diff)

#14 in reply to: ↑ 9 ; follow-up: @CarolKn
17 months ago

Replying to azaozz:

Sounds like the hosting company is inserting/appending a string (tracking pixel) to the JS file? Ugh...

In any case, this doesn't seem to be an issue in core. Manipulating JS files is a big no-no! Please contact your host and open a thread on the support forum to track any progress.

Thank you @azaozz!

#15 in reply to: ↑ 14 @burningthumb
17 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

YES! This is it. I looked on Windows using the Edge Browser and indeed this is the case.

So I called Telus back, and this time they knew exactly what the problem was as well. They say the pixel track has always been on and its a problem with wordpress 5.1 and later.

Funny now everyone seems to know it.

I only had to talk to 3 people at Telus and two good folk here.

Rest easy.

Replying to CarolKn:

Replying to azaozz:

Sounds like the hosting company is inserting/appending a string (tracking pixel) to the JS file? Ugh...

In any case, this doesn't seem to be an issue in core. Manipulating JS files is a big no-no! Please contact your host and open a thread on the support forum to track any progress.

Thank you @azaozz!

This ticket was mentioned in Slack in #forums by ipstenu. View the logs.


17 months ago

#17 follow-up: @gcphoto
17 months ago

Does anyone know if this issue going to be addressed and fixed in the next version of WP or is it something that has to be addressed by the Web Host?

Thanks
Garry

#18 in reply to: ↑ 17 ; follow-up: @CarolKn
17 months ago

Replying to gcphoto:

Does anyone know if this issue going to be addressed and fixed in the next version of WP or is it something that has to be addressed by the Web Host?

Thanks
Garry

Your best bet is getting it fixed by the web host.

#19 in reply to: ↑ 18 @gcphoto
17 months ago

Replying to CarolKn:

Replying to gcphoto:

Does anyone know if this issue going to be addressed and fixed in the next version of WP or is it something that has to be addressed by the Web Host?

Thanks
Garry

Your best bet is getting it fixed by the web host.

Thank you, I did just that and it solved the problem. It was so easy to Fix but so Hard to Find.
Garry

#20 follow-ups: @smartabhay27
17 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

same here iam also unable to edit on my homepage in version 5.1.1..can anyone plz help and support how to resolve..? iam struglling from last 10 days and i have to release my site urgently...

if its a bug in new version then what is the way to roll back to the older version ?

#21 in reply to: ↑ 20 @CarolKn
17 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Replying to smartabhay27:

same here iam also unable to edit on my homepage in version 5.1.1..can anyone plz help and support how to resolve..? iam struglling from last 10 days and i have to release my site urgently...

if its a bug in new version then what is the way to roll back to the older version ?

Assuming your problem is the same as above, your hosting company is causing this problem by inserting code into various files on the website. Call them and ask them to turn off tracking pixels. Tracking pixels are sometimes used to generate statistics, but in this case they are getting into places they shouldn't be.

#22 in reply to: ↑ 20 @burningthumb
17 months ago

To my mind, not everyone will agree, its a wordpress v5.1 bug. My hosting company has had tracking pixels turned on for YEARS and previous version of Wordpress worked fine. I backed out to v5.0.3 and it works fine.

Having said that, the Wordpress developers are among those who don't agree with my assessment and as such are not, so far as I can tell by responses here, prepared to accept responsibility and fix the bug. So if you want a solution, as I and other did, get your hosting company to turn off tracking pixels / statistics, you are probably not using the statistics that it gathers anyway - I wasn't.

Replying to smartabhay27:

same here iam also unable to edit on my homepage in version 5.1.1..can anyone plz help and support how to resolve..? iam struglling from last 10 days and i have to release my site urgently...

if its a bug in new version then what is the way to roll back to the older version ?

#23 @smartabhay27
17 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#24 @smartabhay27
17 months ago

can someone inform the process of rolling back to older version of wordpress and will that impact my functional site by anyways ?

#25 @knutsp
17 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Hello @smartabhay27

Since this is not a support channel, please search for this on the support sitehttps://wordpress.org/support/ or through a general search engine.

This ticket was, and should be closed because the OP's problem turned out not to be a core bug.

#26 @smartabhay27
17 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

How can you say that its not a core bug..everyone on this forum is saying that they are facing updating issues in 5.1 version of wordpress...and you are just trying to pass on the problem on the hosting team..how was everything working fine on your older version ??

by the way i have already checked with hosting team...it has nothing to do with their pixels... its a core word press new version issue...either kindly rectify it or arrange to roll us back to the older version..atleast there should be a provision for us to use either a new verss=ion or a old version which ever suits our website..or else guide us with steps how to roll back to older version without impacting the site.

#27 follow-up: @azaozz
17 months ago

  • Resolution set to invalid
  • Status changed from reopened to closed

@CarolKn and @knutsp are right. This is not an issue in WordPress. It's not even an issue exactly with the web hosting companies, it's some software they are using turns out to be buggy.

@smartabhay27 imagine the post office opening your letters, cutting them in half and sticking a paragraph written in... Latin in the middle. Would you blame the sender of the letters then? :)

I have no idea why somebody would append a HTML string in the middle of a JavaScript file. This is bound to fail in almost all cases. Perhaps they had a good reason for doing it, but... It breaks sites.

I also don't know why this started happening now. The file being affected is not from WordPress itself. It comes from the TinyMCE open source project and WP doesn't modify it in any way. My guess is that it started matching some sort of pattern so the pixel inserting software decided it's OK to add HTML tags there. I'd like to repeat that inserting HTML strings in JS files seems like a really bad idea in the first place, and that software should be fixed.

#28 in reply to: ↑ 27 ; follow-ups: @smartabhay27
17 months ago

so what do you suggest i should do ?

my hosting team has clearly denied any error from their side and any insertion of pixels etc and none of the error logs state any error...except that iam hitting max 1GB RAM limit which is strange since my site is very very basic.

Also note my issue is that iam unable to update my homepage where all other pages are getting updated easily.

i have deactivated all plugins but still error is there...as per hosting team i need to upgrade to a higher RAM plan but thats not a solution since my site is very very basic so why is it eating so much RAM with hardly any plugins and images on my site ?

Replying to azaozz:

@CarolKn and @knutsp are right. This is not an issue in WordPress. It's not even an issue exactly with the web hosting companies, it's some software they are using turns out to be buggy.

@smartabhay27 imagine the post office opening your letters, cutting them in half and sticking a paragraph written in... Latin in the middle. Would you blame the sender of the letters then? :)

I have no idea why somebody would append a HTML string in the middle of a JavaScript file. This is bound to fail in almost all cases. Perhaps they had a good reason for doing it, but... It breaks sites.

I also don't know why this started happening now. The file being affected is not from WordPress itself. It comes from the TinyMCE open source project and WP doesn't modify it in any way. My guess is that it started matching some sort of pattern so the pixel inserting software decided it's OK to add HTML tags there. I'd like to repeat that inserting HTML strings in JS files seems like a really bad idea in the first place, and that software should be fixed.

#29 in reply to: ↑ 28 @burningthumb
17 months ago

I had this same problem with Telus (my hosting company), the first 2 guys I talked to had no clue, I gave them an admin account on my web site and they made it worse by disabling plugins that were not the cause of the problem. The second guy I spoke to told me to go to another hosting company since they did not support Wordpress content. The third guy I spoke to knew exactly what to do and fixed it, it was very frustrating. I will switch hosting companies (moving to godaddy.com) at the end of my current year.

You can roll back to Wordpress v5.0.3 using the plugin WP Downgrade (https://wordpress.org/plugins/wp-downgrade/) its a bit scary and leave some v5.1 files in place but for me it worked 100%. Wordpress itself does not seem to have a downgrade capability builtin which was a bit surprising.

I'm not sure what is different between v5.0.3 and v5.1.1 and as you see there is an exercise in finger pointing going on.

Extremely frustrating since 99% of hosting companies are not using the problem analytics package. It seems to be Telcos: ATT, Telus, and I believe a read a post from someone in the UK where the Telco there had the same problem.

If you login to your hosting control panel you will probably find an analytics package that you can turn off which will solve the problem as well - it was the permanent solution for me that allowed me to upgrade back to Wordpress v5.1.x.

Replying to smartabhay27:

so what do you suggest i should do ?

my hosting team has clearly denied any error from their side and any insertion of pixels etc and none of the error logs state any error...except that iam hitting max 1GB RAM limit which is strange since my site is very very basic.

Also note my issue is that iam unable to update my homepage where all other pages are getting updated easily.

i have deactivated all plugins but still error is there...as per hosting team i need to upgrade to a higher RAM plan but thats not a solution since my site is very very basic so why is it eating so much RAM with hardly any plugins and images on my site ?

Replying to azaozz:

@CarolKn and @knutsp are right. This is not an issue in WordPress. It's not even an issue exactly with the web hosting companies, it's some software they are using turns out to be buggy.

@smartabhay27 imagine the post office opening your letters, cutting them in half and sticking a paragraph written in... Latin in the middle. Would you blame the sender of the letters then? :)

I have no idea why somebody would append a HTML string in the middle of a JavaScript file. This is bound to fail in almost all cases. Perhaps they had a good reason for doing it, but... It breaks sites.

I also don't know why this started happening now. The file being affected is not from WordPress itself. It comes from the TinyMCE open source project and WP doesn't modify it in any way. My guess is that it started matching some sort of pattern so the pixel inserting software decided it's OK to add HTML tags there. I'd like to repeat that inserting HTML strings in JS files seems like a really bad idea in the first place, and that software should be fixed.

#30 in reply to: ↑ 28 @CarolKn
17 months ago

Replying to smartabhay27:

so what do you suggest i should do ?

my hosting team has clearly denied any error from their side and any insertion of pixels etc and none of the error logs state any error...except that iam hitting max 1GB RAM limit which is strange since my site is very very basic.

Also note my issue is that iam unable to update my homepage where all other pages are getting updated easily.

i have deactivated all plugins but still error is there...as per hosting team i need to upgrade to a higher RAM plan but thats not a solution since my site is very very basic so why is it eating so much RAM with hardly any plugins and images on my site ?

Replying to azaozz:

@CarolKn and @knutsp are right. This is not an issue in WordPress. It's not even an issue exactly with the web hosting companies, it's some software they are using turns out to be buggy.

@smartabhay27 imagine the post office opening your letters, cutting them in half and sticking a paragraph written in... Latin in the middle. Would you blame the sender of the letters then? :)

I have no idea why somebody would append a HTML string in the middle of a JavaScript file. This is bound to fail in almost all cases. Perhaps they had a good reason for doing it, but... It breaks sites.

I also don't know why this started happening now. The file being affected is not from WordPress itself. It comes from the TinyMCE open source project and WP doesn't modify it in any way. My guess is that it started matching some sort of pattern so the pixel inserting software decided it's OK to add HTML tags there. I'd like to repeat that inserting HTML strings in JS files seems like a really bad idea in the first place, and that software should be fixed.

@smartabhay27 it sounds like you may have a different issue. I could not edit ANY page or post of the problem website with the visual editors.

TinyMCE had significant changes that were put out about the same time as WP 5, and as @azaozz writes, it's likely the new code triggered the insertion by the stat software. When I used web developer console to look at the errors, it pointed me to the file that was corrupted. When I finally actually looked at it (who looks at minified files!?) it was obvious why it wasn't working: massive code insertion that didn't belong in a JS file. I couldn't see it via FTP because it happens between the server and client as the page is rendered. I'm sending these details because at the point where I saw the bad code, I could have sent that to my hosting company and proven that it was their software that caused the problem. Fortunately I didn't have to do that and fixed it myself in about 5 minutes. You should be able to follow those steps to debug your problem to confirm whether this is indeed the issue or ascertain whether there is a different problem on your site.

Note: See TracTickets for help on using tickets.