WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 14 months ago

Last modified 14 months ago

#46458 closed enhancement (duplicate)

Add the Health Check plugin as a quick-install under "Available Tools"

Reported by: Clorith Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Site Health Keywords: site-health
Focuses: Cc:

Description

The Available Tools section does not currently contain a lot of content, right now it only contains a tags and categories converter.

The Health Check & Troubleshooting plugin has shown it self to be a valuable tool, and parts of it are planned to make it into core during this year (as part of the 9 projects for 2019), but not everything fits the core philosophies, and should remain in the plugin.

The plugin also allows for more rapid iterations of changes or tests that need to be introduced, making it great for introducing core-intended checks ahead of time.

Not everything in the Health Check plugin is ready for core yet, but the features in the public plugin are valuable. The plugin is already listed as a featured plugin, and fairly easy to find that way, granted it comes low down due to the install count priority there.
In light of this, I propose adding a quick install option for the plugin to the Available Tools section. It would simplify the process of finding and enabling it for end users, as I observe tutorials and explanations going through the process of explaining how to get at it from plugin searches.

Change History (4)

#1 @desrosj
14 months ago

  • Component changed from General to Administration
  • Keywords site-health needs-patch added

Hey @Clorith!

A lot has changed in 3 months :)

I don't think adding this to the Tools page is a bad idea. However, it should obviously now direct the user to the Site Health page in Core instead. There was also some talk about adding a card to the Tools page for the privacy tools introduced in 4.9.6 (see #43854).

If a card is added, it should also respect the view_site_health_checks capability introduced in [45507].

#2 @garrett-eclipse
14 months ago

  • Keywords close added

Thanks @desrosj marking with 'close' here as there's #46745 already for introducing a card for Site Health onto the Tools page. I've added your note about view_site_health_checks to that ticket.

#3 @desrosj
14 months ago

  • Keywords needs-patch close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #46745.

Thanks, @garrett-eclipse! I missed that one. Definitely more progress over there.

#4 @spacedmonkey
14 months ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.