WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 23 months ago

Last modified 23 months ago

#46473 closed defect (bug) (duplicate)

Whitespace in XML and .htaccess

Reported by: masterforwordpress Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Export Keywords:
Focuses: Cc:

Description

Version 5.1 contains some kind of indent or bug, that affects other files. When exporting content, incomprehensible indents appear in the .xml file, this indent can also be seen in the networth setup (for .htaccess)
https://www.screencast.com/t/S74itxpie

Attachments (2)

2019-03-11_1456.png (24.7 KB) - added by SergeyBiryukov 2 years ago.
The attachment from ticket description
2019-03-15_1055.png (173.7 KB) - added by masterforwordpress 2 years ago.

Download all attachments as: .zip

Change History (13)

#1 @desrosj
2 years ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

Hi @masterforwordpress,

Welcome to Trac!

Can you be more specific about which XML files you are referencing? Is this causing undesired behavior? Or just strange formatting?

@SergeyBiryukov
2 years ago

The attachment from ticket description

#2 @SergeyBiryukov
2 years ago

Uploaded the image from ticket description as an attachment for clarity.

#3 @masterforwordpress
2 years ago

Starting with version 5.1, incomprehensible indents appeared. they don’t depend on plugins, I don’t know exactly what they’re affecting, but for me the biggest problem is incorrect XML formatting that needs to be edited manually (remove indents) in order to display the content correctly. There were also errors in the plugins associated with the contact forms. I assume that there is some kind of indent (2 tabs) that affects the export of files, as well as in the network settings on the htaccess setting.

Last edited 2 years ago by masterforwordpress (previous) (diff)

#4 @masterforwordpress
2 years ago

if I use the usual wp export, then the export file is broken. this is definitely not related to plugins, themes, and the correctness of filling with content. I am sure of this since this problem is not only mine, and it has not been tested many times. Incorrect formatting of the xml file, breaks a lot of content during import. mostly pages and forms

Last edited 2 years ago by masterforwordpress (previous) (diff)

#5 @masterforwordpress
2 years ago

  • Severity changed from normal to major

#6 @desrosj
23 months ago

  • Keywords close added

Related: #46922, #46575.

The two related tickets above were fixed in 5.2 (see [45208], [45215], and [45216]). These changes should have fixed the issues in the screenshot that was uploaded.

I have not been able to reproduce the white space in .htaccess.

@masterforwordpress can you confirm if you are still seeing the issue, and where?

#7 @desrosj
23 months ago

  • Severity changed from major to normal

#8 @masterforwordpress
23 months ago

@desrosj, yes. Problem from my ticket in 5.2 were fixed, thank you! The formatting in xml looks better.
White space in .htaccess stayed, but this not a problem for me. Multisite (Network Setup > 2nd item {settings for htaccess})

#9 @desrosj
23 months ago

  • Keywords reporter-feedback close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from Space in WP 5.1 to Whitespace in XML and .htaccess

Duplicate of #46922.

Thanks for confirming, @masterforwordpress. Happy that this was fixed for you in 5.2!

I did some more testing but I could not replicate the space in .htaccess. If you are still able to reproduce that, feel free to reopen with more details.

#10 @SergeyBiryukov
23 months ago

The .htaccess issue is being tracked in #47062.

#11 @SergeyBiryukov
23 months ago

  • Component changed from General to Export
Note: See TracTickets for help on using tickets.