WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

#46502 closed defect (bug) (worksforme)

Twenty Nineteen columns block alignment repair for more than two columns

Reported by: hanheg Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

In twentynineteen the columns in a column block misalign on screens between 600 and 782 pixels due to a missing margin-left. This line of CSS corrects that for the theme in the patch file attached.

Attachments (1)

fix-columns.patch (460 bytes) - added by hanheg 4 months ago.

Download all attachments as: .zip

Change History (5)

@hanheg
4 months ago

#1 @hanheg
4 months ago

  • Keywords has-patch added

#2 follow-up: @kjellr
3 months ago

Hi @hanheg! Thanks for filing the issue. Would it be possible to share a screenshot of the issue you're seeing? It's possible that the issue you're experiencing is one of the ones noted in #46999.

Also, it looks like the CSS rule you've added in your patch actually already exists in style.css here:

https://themes.trac.wordpress.org/browser/twentynineteen/1.3/style.css#L6022

In #46999, I actually found that moving that flex-wrap: nowrap; rule from the mobile breakpoint (600px) into the tablet breakpoint (768px) solved some issues with the latest version of Gutenberg.

Thank you!

#3 in reply to: ↑ 2 @hanheg
3 months ago

Hi @kjellr

thanks for looking into this. I looked at it to make a screenshot but the problem is gone in 1.3.
I'm not sure how this works but apparently someone applied the same patch.

You can see the problem when you take out that CSS rule. Than it looks like this:

http://tweebis.com/cursus/wp-content/uploads/2019/04/2019-04-23.png

I think moving the breakpoint into the tablet breakpoint might reintroduce this problem. The column block misaligned when more than two columns were used and when it wrapped.
But in the meantime lot's has change so maybe it works.

Hi, Han

#4 @kjellr
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Ok, thanks @hanheg! Since we can't reproduce here I'll close this issue for now. I'll keep my eye open for any breakage in the other ticket. 👍

Note: See TracTickets for help on using tickets.