WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#46527 closed defect (bug) (invalid)

Gutenberg embed URL block only works in some cases

Reported by: justinahinon Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Embeds Keywords: has-screenshots
Focuses: Cc:

Description

I'm trying to embed a website on a page with the Gutenberg embed block, but it only works for some URL and not others.

I'm running on WordPress 5.1.1 with the theme Hestia.

Here are some examples:

Embed https://www.google.bj/
No image "embed-bug-1.png" attached to Ticket #1

Embed https://www.google.bj/ result in front-end
No image "embed-bug-1-1.png" attached to Ticket #1

Embed https://wordpress.org
No image "embed-bug-3.png" attached to Ticket #1

Embed https://info.africarxiv.org, the website I'm working on. The website displays in the editor
No image "embed-bug-4.png" attached to Ticket #1

Embed https://info.africarxiv.org, result in front-end
No image "embed-bug-5.png" attached to Ticket #1

I tried to reproduce these on a local server, and I ran into the sames issues.
Note that, when I embed a Twitter/YouTube post with the specific embeds blocks, it works correctly both in the editor and in front-end.

Attachments (5)

embed-bug-1.png (11.4 KB) - added by justinahinon 2 years ago.
embed-bug-1-1.png (3.7 KB) - added by justinahinon 2 years ago.
embed-bug-3.png (11.2 KB) - added by justinahinon 2 years ago.
embed-bug-4.png (71.6 KB) - added by justinahinon 2 years ago.
embed-bug-5.png (11.6 KB) - added by justinahinon 2 years ago.

Download all attachments as: .zip

Change History (8)

#1 @swissspidy
2 years ago

  • Component changed from General to Embeds
  • Focuses accessibility removed
  • Severity changed from major to normal

That looks as expected to me.

You cannot just embed any website on the internet. The websites need to support oEmbed. I don't think the Google homepage does support oEmbed, for example :-)

#2 @jeremyfelt
2 years ago

  • Keywords close added

It looks like the https://info.africarxiv.org/ home page advertises an oEmbed URL of https://info.africarxiv.org/embed/, which redirects back to https://info.africarxiv.org/ and causes the unstyled/confusing embed in the editor.

Other pages such as https://info.africarxiv.org/about/ work fine with the advertised https://info.africarxiv.org/about/embed/.

I tested another site with a static page set for the home page and it also advertises the endpoint incorrectly. I wonder if there could be a bug there? Somewhat related: #35067

(I think this ticket can be closed, though I am wondering about the static home page embed now) :)

Related to the linking of non-oEmbed supporting URLs: https://github.com/WordPress/gutenberg/pull/12095 added the "Try again" and "Convert to link" options to make the experience a little better when using a URL that does not support oEmbed.

#3 @desrosj
2 years ago

  • Keywords has-screenshots added; needs-screenshots close removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing this ticket out as it seems to be working as expected. @justinahinon if you are still having issues and feel this should remain open, please feel free to reopen with more details!

Note: See TracTickets for help on using tickets.