WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#46552 closed defect (bug) (reported-upstream)

Page Preview not working

Reported by: sumitbagthariya16 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Editor Keywords:
Focuses: Cc:

Description

The “preview” function no longer works on multiple sites, running different themes, when editing published pages or posts

Change History (6)

#1 @sumitbagthariya16
17 months ago

  • Version set to 5.1

#2 @mukesh27
17 months ago

  • Component changed from General to Editor
  • Keywords reporter-feedback added

Hi @sumitbagthariya16, Welcome to WordPres Trac! Thanks for the report.

Does the issue still happen with all plugins disabled and a default theme (Twenty Nineteen) activated?

i can't replicate above issue in fresh install WordPress 5.1.1

Last edited 17 months ago by mukesh27 (previous) (diff)

#3 @earnjam
17 months ago

This sounds like: https://github.com/WordPress/gutenberg/issues/12617

That is a confirmed bug where when the block editor has meta boxes, it won't display the preview on the first preview window load. If you wait a few seconds for an autosave to fire in the background, and then click refresh, it may work.

@sumitbagthariya16 can you confirm whether this is happening with no plugins active and the default theme?

If it happens with no plugins active and the default theme (i.e. no metaboxes), then we have an open issue to try to track that situation here: https://github.com/WordPress/gutenberg/issues/13232
Some users have reported previews not working even when no metaboxes are loaded, but we haven't been able to confirm that yet.

#4 @sumitbagthariya16
17 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #12617.

This ticket was mentioned in Slack in #core by jayupadhyay01. View the logs.


17 months ago

#6 @earnjam
17 months ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution changed from duplicate to reported-upstream
Note: See TracTickets for help on using tickets.