WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 6 months ago

#46612 closed feature request (maybelater)

The Next Leap Forward for WordPress: Business Operations Data Application Development (BODAD) Capability

Reported by: dmillerweb Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

WordPress is the unquestioned leader for building new websites, either by people or businesses managing their own sites, or increasingly by developers building websites for clients. In spite of the fact that WordPress is a database-driven application, and already has some robust database tools, there is currently NO capability for WordPress website developers to build database applications to run the operations of their business or organization.

While there ARE some plugins that allow building tables and even SaaS applications for database application, all of them fall short in affordability, flexibility, documentation, completeness, and/or ease-of-use.

PROPOSAL: Develop a Business Operations Data Application Development (BODAD) capability for WordPress. This should either be a part of the WordPress core, or a fork of WordPress, so developers can download a core with this capability or without it.

SPECIFICATIONS OUTLINE: A more complete proposal and outline of the specifications for this BODAD project are in a Google Document, at
https://docs.google.com/document/d/1k4Y5bc2ES3bsLfhrz8tcP36bV85kWAbgkRXYS91PY08/edit?usp=sharing

MY ROLE: I have more than 35 years programming experience, more than 20 years experience developing business database applications, including 5 years as project manager. I have been building websites since 1995 and began working with WordPress in 2009. While I have moderate fluency with PHP and MySQL, I am relatively inexperienced in the WordPress Core, but would be happy to work with the project management team to bring this project about.

BENEFITS: This project will be the "Next Leap Forward for WordPress" in that it will expand its capabilities beyond being the best brochure-style website platform in the world, to being the platform of choice for the hundreds of thousands of developers with clients who need an online, database-driven, business operations management system.

I am enthusiastic and confident that this project is needed, wanted, and will see a mushrooming explosion of demand as more and more developers see what they can do with it.

Finally, I'm not sure what to do from this point, so I'm turning it over to you, the WordPress core development team, with a request to let me know how I can help with the project.

Thanks, and take care,

David in Mississippi

Change History (9)

#1 follow-up: @earnjam
6 months ago

  • Keywords Database Application Development removed
  • Severity changed from major to normal
  • Version trunk deleted

#2 in reply to: ↑ 1 @dmillerweb
6 months ago

Replying to earnjam: Thanks for your amendments - I'm still learning here. It would help me learn if you could share with me why you made those changes. If not, no problem, I'll try to learn by absorption.

#3 @afercia
6 months ago

@dmillerweb thanks for your feature request. Keywords and ticket properties are used to generate reports on this bug tracker (also known with the loving name of "Trac").

Custom, manually set, keywords are sometimes used to group together tickets that don't fall into one of the preset keywords. Yout ticket is unique so maybe a custom keyword is not necessary. See https://make.wordpress.org/core/handbook/contribute/trac/keywords/

Severity and Priority are more appropriate to bugs rather than feature requests, see https://make.wordpress.org/core/handbook/contribute/trac/#ticket-properties

Version: mainly used to indicate the earliest version affected by a bug.

Pretty sure those changes were not meant to dismiss your proposal in any way :) Thanks again.

#4 @earnjam
6 months ago

Apologies @dmillerweb! I think @afercia explained it very well. Definitely did not mean to be dismissive.

I was just doing some triage when I saw the ticket come in to ensure it matches our usual workflows.

#5 @mdwolinski
6 months ago

Hi David,

First, I'm not a core developer. I am, however, a Project Manager/Developer of internal enterprise sites for a large global entertainment company. So, take my perspective with that grain of salt.

From reading through your linked Google document, it would appear to me that you're essentially suggesting a reporting tool along the lines of Tableau or Business Objects. More so Business Objects with it's ability to create universes that connect multiple datasources together into one.

I'm wondering why you feel this would need to be part of core?

It seems to me that what you're proposing would be ideal as a plugin, whether developed by Automattic, an independent developer or you (or a developer you hire ;-).

The reasoning behind it being developed as a plugin is two fold, first from my understanding any new added functionality to the core is first developed as a plugin to test it out before it's merged into core (see Gutenberg as an example).

Second, the functionality you're proposing doesn't need to be part of core to be functional, ie it gains nothing by being included as part of core. So, if developed as a plugin, then it can be installed by anyone who would be interested in such features (see WooCommerce, Jetpack, bbPress, BuddyPress all great and robust functionality added as plugins)

There are probably businesses (and individuals) who would certainly appreciate by having a robust reporting tool available to them within WordPress, especially if it comes with prebuilt reports based on the WordPress tables. I could certainly see companies who could potentially develop this as a plugin to build a business around. Could also be a great feature plugin used by WordPress VIP and their customer base.

Interesting idea, but as someone who has used many reporting tools in the corporate environment, not easy to get right or easy to use.

#6 @dmillerweb
6 months ago

@mdwolinski Thanks for that input. Developing this concept as a plugin would be just fine. I'm not cemented into core integration on this. I appreciate your perspective.

In any case, I am thoroughly convinced we NEED this capability, and so far, it's just not there.

While I don't have your experience with corporate reporting, I do have more than a dozen years experience building database-driven applications which large companies and small businesses use to run much of their day-to-day operations. These are NOT just reporting tools, unless I have a mistaken impression of what you mean by that.

I believe it would be ideal to have this furnished by WordPress or Automattic, but I'd be tickled to work with any provider that wants to put together a tool like this that would be eminently usable by any intermediate-level WordPress developer.

Sigh. It may be that I have to bite the bullet and go hire some programmers to write this for me, but I'm not sure I'm ready for that. Yet.

Thanks again.

#7 @jorbin
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to maybelater
  • Status changed from new to closed

@dmillerweb thanks for proposing this idea. I am sure that for many it has the potential to provide a lot of value.

That said, the WordPress Roadmap has 9 focuses for 2019 and some fairly large project for after that as well and all continue the idea of WordPress being software for website management along the lines of the project's mission to democratize publishing.

So for the foreseeable future, I view this as plugin territory.

#8 @jorbin
6 months ago

BTW, discussion can absolutely continue with the ticket status set to closed, but I wanted to be realistic about the likelihood of the core team working on this in the immediate future. And tickets can be re-opened given new information.

#9 @mdwolinski
6 months ago

@dmillerweb wanted to give you a little bit more feedback directly related to your idea. The Google document can use a good rewrite that would help you and any eventual developer get a clearer picture of what your goal is.

I'd recommend removing all the fluff from the document. The fluff being anything that's not related to a more technical view of what you're proposing. Telling me that this idea is the best thing since peanut butter met jelly doesn't give me any idea about what the benefit of your proposal is to me. Save all of that marketing pitch until you have a product that you can sell (whether for money or not).

Between my reading of the document and your comments, I feel like you understand more of what you want that's not clearly shown in the write up. Nothing wrong with that. Everyone writes things down thinking other people just know things they don't.

Start out with defining what the problem is. You can certainly pull from your current experience. For example, Business Operations Data Application allows the user to create a distinct collection of fields from multiple, related DBs and easily create and edit new rows of data.

Define what is already out there that may provide, albeit not via WordPress, that provides the kind of solutions your looking to build. Could be Microsoft Access, could be Business Objects, etc. Then anyone you're working with now has a visual of functionality you believe they need. Any product you list is going to have positives and negatives, so make sure to include that info about what functionality you think is missing.

In my corporate world, when we are approached with a request to build something, the first thing we do is give them an Excel document and say, "Write out your user stories."

This document makes them think about the district functionality of their request which is broken into Epics. So, for example, one Epic could be Welcome/Navigation Pages, another Locate Manager Funds Page. Then each Epic is broken down into distinct actions on that page, like As the user, I want to be able to select the manager funds page so I can be direct to the correct page.

You may also benefit from creating some Balsamiq mockups as well, visuals help so much in explaining things.

And don't be discouraged by others and my comments. I'm currently building a new SaaS service which I have a clear picture of what it's going to do and how it's going to benefit people. I tried to explain it to a co-worker and it took 20 minutes of explaining what I thought was a *simple* concept. I went back to my developer and admitted I need to work on my elevator pitch.

Feel free to ask any questions you want, I'm on the WP Slack at Mark W Same profile image I have here.

Good luck!

Note: See TracTickets for help on using tickets.