WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 33 hours ago

Last modified 12 hours ago

#46619 closed enhancement (fixed)

Introduce 'Mark as Completed' action and bulk action to the privacy export requests

Reported by: garrett-eclipse Owned by: garrett-eclipse
Milestone: 5.6 Priority: normal
Severity: normal Version:
Component: Privacy Keywords: has-patch has-screenshots needs-testing
Focuses: ui, administration Cc:

Description

Hello,

Branching an enhancement idea out of the #44644 bug to request introducing a 'Mark as Completed' action to the privacy export requests table items along with a bulk action for the functionality.

In many cases the admin will download the export file and email the user with a customized template, the 'Mark as Completed' action allows the admin to move the request to the completed state if it was acted upon externally to the default workflow.

Below are some quotes of the discussion in #44644 for reference;

My initial comment;

As well to support the case where admin wants to download the export and craft their own email we should introduce a 'Mark Completed' list action to the rows that are currently in Confirmed state so they can still push the request through the workflow but avoid the autogenerated email.

Comment by @desrosj suggesting the bulk action

Introduce a way to manually mark a request as completed for instances where an administrator downloads the user's data and emails it separately. I was thinking of another action link near the download link, and maybe a bulk action.

Design feedback from @JoshuaWold

I like the idea of giving them a way to complete the request. I just want to make sure I understand the user need here. What is the typical scenario for this kind of a request to happen? Does a user ask for it and then the admin needs to supply it?
Either way, having "Mark as completed" as part of the bulk actions makes sense. Especially since I'm assuming we could move it back to "Pending" if the admin made a mistake or something changed. At the moment (unless there's something I'm missing about the admin needs here, and they will be doing this action often) I don't think adding another button, apart from the bulk actions, makes sense; seems like it'd be making it more busy.

As @JoshuaWold's questions weren't answered in the original ticket am doing so here;

  • Currently, in core the admin would initiate the request most likely as a user requested it. And in many cases the admin has to comply due to GDPR regulation.
  • Once a request is completed it can be re-initiated by re-requesting with the username or email. Note: This wasn't the case before #44707 which was committed to 5.2 recently.
  • In my opinion I feel adding another action link on the request row will be more useful to the admin than the bulk (I also believe the bulk to be useful), this being because it's visible and in many cases admins are action on individual requests over multiple (at least in my experience).

All the best

Attachments (8)

46619.diff (6.2 KB) - added by garrett-eclipse 2 weeks ago.
Initial patch
Screen Shot 2020-10-08 at 1.02.46 AM.png (145.4 KB) - added by garrett-eclipse 2 weeks ago.
Bulk Actions
Screen Shot 2020-10-08 at 1.00.41 AM.png (15.6 KB) - added by garrett-eclipse 2 weeks ago.
Row Action
Screen Shot 2020-10-08 at 1.03.00 AM.png (12.1 KB) - added by garrett-eclipse 2 weeks ago.
Confirmation notice
46619.2.diff (7.5 KB) - added by garrett-eclipse 33 hours ago.
Refresh to drop inline-block CSS and change divs to spans for actions. Also conditionally suppress the Mark as Completed on completed requests.
46619.3.diff (7.6 KB) - added by garrett-eclipse 33 hours ago.
Missed needing to declare variables before use.
46619.4.diff (7.6 KB) - added by garrett-eclipse 33 hours ago.
Fix the missing request_id as it was inside a conditional.
46619.5.diff (9.6 KB) - added by garrett-eclipse 33 hours ago.
Update to sentence case for privacy actions.

Download all attachments as: .zip

Change History (23)

@garrett-eclipse
2 weeks ago

Initial patch

#1 @garrett-eclipse
2 weeks ago

  • Keywords has-patch needs-testing has-screenshots added
  • Milestone changed from Awaiting Review to 5.6
  • Owner set to garrett-eclipse
  • Status changed from new to accepted

I've uploaded an initial patch 46619.diff for introducing the bulk and row actions for Mark as Complete.

As it aligns with #44266 and #44081 I'm moving into 5.6 to see if we can get them in together. Once either of these is committed this will need refreshing.

This ticket was mentioned in Slack in #core-privacy by hellofromtonya. View the logs.


7 days ago

This ticket was mentioned in Slack in #core-privacy by hellofromtonya. View the logs.


3 days ago

This ticket was mentioned in Slack in #core-privacy by garrett-eclipse. View the logs.


35 hours ago

#5 @Mista-Flo
34 hours ago

  • Keywords needs-testing removed

Hi there, I have tested the patch, it works as expected.

I have also reviewed the code and it's good quality, well done Garrett :)

Let's commit it!

#6 @garrett-eclipse
34 hours ago

  • Keywords commit added

Thanks @Mista-Flo you rock.

#7 @mukesh27
34 hours ago

Tested the patch, it working fine.

#8 @carike
34 hours ago

Tested on live single-site installation.
A complete request link now appears. Tested for two export requests - one which was confirmed and one which was awaiting confirmation. Both showed as completed.
Tested for one erasure request (awaiting confirmation). Shows as completed.

This ticket was mentioned in Slack in #core by helen. View the logs.


34 hours ago

@garrett-eclipse
33 hours ago

Refresh to drop inline-block CSS and change divs to spans for actions. Also conditionally suppress the Mark as Completed on completed requests.

#10 @garrett-eclipse
33 hours ago

  • Keywords needs-testing added; commit removed

Refresh in 46619.2.diff from recent discussions in #core. This converts the <div> in the actions to span and dropps the css. Also conditionally suppressed Mark as Complete from complete requests.

@garrett-eclipse
33 hours ago

Missed needing to declare variables before use.

@garrett-eclipse
33 hours ago

Fix the missing request_id as it was inside a conditional.

#11 follow-up: @ocean90
33 hours ago

After [48352] and [48595], should the bulk action labels use sentence case too?

@garrett-eclipse
33 hours ago

Update to sentence case for privacy actions.

#12 in reply to: ↑ 11 @garrett-eclipse
33 hours ago

Replying to ocean90:

After [48352] and [48595], should the bulk action labels use sentence case too?

Good catch thanks @ocean90 updated in 46619.5.diff

#13 @helen
33 hours ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 49258:

Privacy: Add "Mark as completed" action.

Props garrett-eclipse, ocean90, joostdevalk, mista-flo, helen.
Fixes #46619.

#14 @SergeyBiryukov
32 hours ago

In 49259:

Coding Standards: Fix WPCS issues in [49258].

See #46619.

This ticket was mentioned in Slack in #core-privacy by garrett-eclipse. View the logs.


12 hours ago

Note: See TracTickets for help on using tickets.