WordPress.org

Make WordPress Core

#46624 closed enhancement (duplicate)

Further bump minimum required PHP and SQL versions for the best security and consistency environments in WordPress 5.2+ trunk version.php file.

Reported by: Luciano Croce Owned by: luciano-croce
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: General Keywords: 2nd-opinion needs-dev-note has-patch
Focuses: Cc:
PR Number:

Description

Please change again minimum required PHP and SQL versions for the best security and consistency environments in WordPress 5.2+ trunk version.php file.

The primary scope of bumping PHP and SQL version is

  • Educate users to update your's LAMP / WAMP / MAMP environment's
  • Involved hosting to support more secure and speed environment's
  • Adding new features that requires modernn and new environment's
  • Updating core for run at the best possible levels environment's
  • Releases the best security and maintenance levels environment's

Recently constant $required_php_version was bumped to minimum support PHP 5.6.30

OK this is a best direction but is incositency, because not have "sense" in the original optical.

I think that the minimum PHP was bumped again to the latest 5.6+ available and secure release that is PHP 5.6.40

/**
 * Holds the required PHP version
 *
 * @global string $required_php_version
 */
$required_php_version = '5.6.40';

In the same direction I think that also constant $required_mysql_version was bumped to more recent version SQL 5.5.62 instead of actual legacy SQL 5.0

/**
 * Holds the required MySQL version
 *
 * @global string $required_mysql_version
 */
$required_mysql_version = '5.5.62';

In this direction more users and hosting are "obligated" to modernize your infrastructure with more benefit yo all WordPress Users and Developers.

Finally I suggest to introduce new constant $required_apache_version like this:

/**
 * Holds the required Apache version
 *
 * @global string $required_apache_version
 */
$required_mysql_version = '2.2.34';

Some useful informations about PHP / SQL / Apache

PHP

5.6 / 5.6.40 ~ 28 August 2014 / EOL 31 December 2018 -- Best minimum choice IMHO
7.0 / 7.0.33 ~ 03 December 2015 / EOL 03 December 2018
7.1 / 7.1.26 ~ 01 December 2016 / EOL 01 December 2019
7.2 / 7.2.15 ~ 30 November 2017 / EOL 30 November 2020
7.3 / 7.3.03 ~ 06 December 2018 / EOL 06 December 2021

SQL

5.1 November 14, 2008 ~ 10 years ago 5.1.73 2013-12-03 / EOL December 2013
5.5 December 03, 2010 ~ 08 years ago 5.5.62 2018-10-22 / EOL December 2018 -- Best choice IMHO MariaDB supported
5.6 February 05, 2013 ~ 06 years ago 5.6.43 2019-01-21 / EOL February 2021
5.7 October 21, 2015 ~ 03 years ago 5.7.25 2019-01-21 / EOL October 2023
8.0 April 19, 2018 ~ 10 months ago 8.0.15 2019-02-01 / EOL April 2026

APACHE

1.3 1998-06-06 / 1.3.42 2010-02-03 EOL
2.0 2002-04-06 / 2.0.65 2013-07-10 EOL
2.2 2005-12-01 / 2.2.34 2017-07-11 EOL -- Best minimum choice IMHO
2.4 2012-02-21 / 2.4.38 2019-01-22 EOL

Change History (3)

#1 @Luciano Croce
10 months ago

Sorry I made this update in correction to Apache constant typo:

/**
 * Holds the required Apache version
 *
 * @global string $required_apache_version
 */
$required_apache_version = '2.2.34';

#2 @knutsp
10 months ago

  • Summary changed from Change again minimum required PHP and SQL versions for the best security and consistency environments in WordPress 5.2+ trunk version.php file. to Further bump minimum required PHP and SQL versions for the best security and consistency environments in WordPress 5.2+ trunk version.php file.

It was suggested by @pento in this posthttps://make.wordpress.org/core/2018/12/08/updating-the-minimum-php-version/ so I guess we already on our way. It will be wise to wait a few months and see the effect of Servehappy and Site Health. The percentage using PHP 5.6 must go down substantially.

For Apache, and this really also goes for Mysql, some use other software (Mariadb) with other versioning. Alternatives to Apache is Nginx and IIS. How should that go into version.php?

I'm more for removing sql version from the file and let Servehappy and Site Health take care of a more diverse minimum version.

#3 @jorbin
10 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

I'm closing this as a duplicate of #46594 so that discussion on the specific version of php5.6 can be centralized. If you would like to discuss the proposed new apache minimum version, that would be best in a separate ticket as it's too late to do something like that for WordPress 5.2. Though as mentioned by @knutsp, apache isn't a requirement for running WordPress in the same way that PHP is.

Note: See TracTickets for help on using tickets.