WordPress.org

Make WordPress Core

#46626 closed defect (bug) (duplicate)

Disabled attribute should have values as per HTML standards

Reported by: harshall Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch
Focuses: coding-standards Cc:

Description

According to the WordPress HTML Coding Standards, all attributes must have a value, and must use double- or single-quotes (source).

https://make.wordpress.org/core/handbook/best-practices/coding-standards/html/#quotes

Attachments (1)

46626.diff (4.1 KB) - added by harshall 19 months ago.

Download all attachments as: .zip

Change History (4)

@harshall
19 months ago

#1 @man4toman
19 months ago

Hi @harshall
Please see: #43496

#2 @swissspidy
19 months ago

  • Component changed from General to Administration

I think we should just update these guidelines in the handbook instead :-)

"According to the W3C specifications for XHTML […]"

We switched to a proper HTML 5 doctype in the admin a long time ago, see #18202

#3 @swissspidy
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #43496.

Note: See TracTickets for help on using tickets.