WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

#46632 closed enhancement (fixed)

Improve the npm dependency caching strategy on Travis CI

Reported by: johnbillion Owned by: johnbillion
Milestone: 5.2 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords:
Focuses: Cc:

Description

See [44989]. Caching $HOME/.npm instead of node_modules is preferable because the latter can cause issues if the cached modules were compiled using a newer version of node. This situation can occur when Travis falls back to the default branch cache.

Change History (12)

#1 @johnbillion
4 months ago

In 44993:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

See #46632

#2 @johnbillion
4 months ago

In 44994:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 5.1 branch.

See #46632

#3 @johnbillion
4 months ago

In 44995:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 5.0 branch.

See #46632

#4 @johnbillion
4 months ago

In 44996:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.9 branch.

See #46632

#5 @johnbillion
4 months ago

In 44997:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.8 branch.

See #46632

#6 @johnbillion
4 months ago

In 44998:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.7 branch.

See #46632

#7 @johnbillion
4 months ago

In 44999:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.6 branch.

See #46632

#8 @johnbillion
4 months ago

In 45000:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.5 branch.

See #46632

#9 @johnbillion
4 months ago

In 45001:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.4 branch.

See #46632

#10 @johnbillion
4 months ago

In 45002:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.1 branch.

See #46632

#11 @johnbillion
4 months ago

In 45003:

Build/Test tools: Switch npm dependency caching strategy on Travis CI.

This switches to caching npm's local cache instead of node_modules in order to prevent issues caused by modules compiled using a different version of node.

Merges [44993] into the 4.0 branch.

See #46632

#12 @johnbillion
4 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.