WordPress.org

Make WordPress Core

#46634 closed task (blessed) (fixed)

Enable fast finishing on Travis CI

Reported by: johnbillion Owned by: johnbillion
Milestone: 5.2 Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: has-patch commit
Focuses: Cc:

Description

With fast finishing enabled, Travis CI will mark your build as finished as soon as one of two conditions are met: The only remaining jobs are allowed to fail, or a job has already failed.

This reduces the time it takes to receive feedback in the #core Slack channel for broken, failing, and newly fixed builds.

Ref: https://blog.travis-ci.com/2013-11-27-fast-finishing-builds/

Attachments (1)

46634.diff (324 bytes) - added by netweb 17 months ago.

Download all attachments as: .zip

Change History (6)

@netweb
17 months ago

#1 @netweb
17 months ago

  • Keywords has-patch commit added
  • Milestone changed from Future Release to 5.2

Previously in [35150] fast_finish: true was removed as it was not working correctly and caused multiple Slack notifications, I reported it upstream in https://github.com/travis-ci/travis-ci/issues/4928#issue-111147790

The above issue I created was closed as a dupe of https://github.com/travis-ci/travis-ci/issues/1696, this issue has since been fixed", so have at it I say @johnbillion

#2 @johnbillion
17 months ago

Interestingly that Travis issue was fixed but several users have been reporting problems since then, most recently in September.

Let's add fast finishing to trunk, then we can backport if we don't see any problems.

#3 @johnbillion
17 months ago

In 45004:

Build/Test tools: Reinstate fast finishing on Travis CI.

This allows for speedier feedback for breaking changes and ongoing failures.

See #46634

#4 @pento
17 months ago

  • Type changed from enhancement to task (blessed)

#5 @jorbin
17 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

Going to call this fixed and close it barring a reason to do otherwise.

Note: See TracTickets for help on using tickets.