WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 3 months ago

#46644 closed defect (bug) (duplicate)

Login not working if user has an email address with an apostrophe

Reported by: licoreo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords:
Focuses: Cc:

Description

As object, if I try to login with email and password where the email has an apostrophe, the system's feedback is that the user is not registered.
However if I try to reset the password or if instead, I insert the username for that email then the operation is successful.

Change History (1)

#1 @desrosj
3 months ago

  • Component changed from General to Login and Registration
  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.1 deleted

Hi @licoreo,

Welcome to Trac!

This seems to be a duplicate of #38744. I am going to close this ticket out because there is already a working patch and discussion over there. Please feel free to add any additional information you have.

Note: See TracTickets for help on using tickets.