WordPress.org

Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 14 months ago

#46677 closed defect (bug) (fixed)

Block plugin updates if required PHP version is not supported - Install screen

Reported by: afragen Owned by: SergeyBiryukov
Milestone: 5.2 Priority: normal
Severity: normal Version:
Component: Site Health Keywords: servehappy has-patch dev-feedback has-screenshots
Focuses: Cc:

Description

It seems if you have an older version of a plugin and you search for the plugin on the Install page you will be prompted to update.

I didn't realize this previously.

Attachments (3)

screenshot_01.png (62.6 KB) - added by afragen 17 months ago.
before
screenshot_02.png (62.7 KB) - added by afragen 17 months ago.
after
46677.diff (1.6 KB) - added by afragen 17 months ago.

Download all attachments as: .zip

Change History (6)

@afragen
17 months ago

before

@afragen
17 months ago

after

@afragen
17 months ago

#1 @SergeyBiryukov
17 months ago

  • Milestone changed from Awaiting Review to 5.2

#2 @SergeyBiryukov
17 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 45043:

Plugins: Disable "Update Now" button for plugins that require a higher version of PHP or WordPress.

This complements disabling the "Install Now" button in [43436].

Props afragen.
Fixes #46677. See #43986.

#3 @spacedmonkey
14 months ago

  • Component changed from Plugins to Site Health
Note: See TracTickets for help on using tickets.