WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

Last modified 4 months ago

#46751 closed defect (bug) (fixed)

Recovery mode: infinite redirect

Reported by: azaozz Owned by: flixos90
Milestone: 5.2 Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: servehappy
Focuses: Cc:
PR Number:

Description

Happens when trying to reactivate faulty plugin that has been deactivated (from the "Paused plugins" screen).

Steps to reproduce:

  1. Introduce a fatal error in a plugin.
  2. Access the site. It will fail to load and trigger Recovery Mode. Click the link in the email and log in.
  3. Go to the "Paused plugins" screen and deactivate the plugin.
  4. Go to "All plugins" and try to reactivate it.

Change History (4)

#1 @afragen
7 months ago

Possibly related. Happens when trying to initially activate a plugin with a fatal.

  1. Create a plugin with a fatal error.
  2. Activate the plugin and Recovery Mode is not triggered.

Difference seems to be when the fatal is introduced, after the plugin has been activated or before.

#2 @flixos90
7 months ago

  • Owner set to flixos90
  • Status changed from new to assigned

#3 @flixos90
7 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 45114:

Bootstrap/Load: Ensure WP_Fatal_Error_Handler does not conflict with existing mechanisms treating fatal errors.

Prior to this change, resuming or activating a plugin or theme that is still broken would result in a redirect loop if in recovery mode. If outside recovery mode, it would cause the error template to be displayed.

Furthermore this applies to breaking a plugin or theme when editing from the backend.

Props aandrewdixon, azaozz, dhanukanuwan, henrywright, ocean90, ohiosierra, PandelisZ, xkon.
Fixes #46045, #46751.

#4 @spacedmonkey
4 months ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.