WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 9 months ago

Last modified 9 months ago

#46776 closed defect (bug) (duplicate)

Add missing translator comments and update about-text function usage in wp-admin/about.php

Reported by: thrijith Owned by: SergeyBiryukov
Milestone: Priority: normal
Severity: normal Version: 5.1
Component: Help/About Keywords:
Focuses: Cc:

Description

Add missing translator comments in wp-admin/about.php

Correct the usage of

<p class="about-text"><?php printf( __( 'Thank you for updating to the latest version!' ), $display_version ); ?></p>

Attachments (1)

46776.patch (5.7 KB) - added by thrijith 15 months ago.

Download all attachments as: .zip

Change History (10)

@thrijith
15 months ago

#2 follow-up: @thrijith
15 months ago

Hi @mukesh27, thanks for pointing this out. Should I add this patch in #46408?

#3 @SergeyBiryukov
15 months ago

  • Component changed from Administration to Help/About

#4 in reply to: ↑ 2 @subrataemfluence
15 months ago

A patch is already added there in #46408 as I can see.

Replying to thrijith:

Hi @mukesh27, thanks for pointing this out. Should I add this patch in #46408?

#5 @SergeyBiryukov
14 months ago

  • Milestone changed from Awaiting Review to 5.3
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing
  • Version changed from trunk to 5.1

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


9 months ago

#7 @davidbaumwald
9 months ago

  • Keywords close added

It looks like this was all resolved in #46408 and its accompanying commits. Marking this for closure.

#8 @garrett-eclipse
9 months ago

  • Keywords has-patch close removed
  • Milestone 5.3 deleted
  • Resolution set to fixed
  • Status changed from reviewing to closed

Thanks for everyone's work on this ticket, I'm closing this as the verbiage has changed and the current trunk has both the proper use of the placeholder along with a translator comment as can be seen here;

<p class="about-text">
    <?php
    printf(
        /* translators: %s: The current WordPress version number. */
        __( 'Congratulations on updating to WordPress %s! This update makes it easier than ever to fix your site if something goes wrong.' ),
        $display_version
    );
    ?>
</p>

https://github.com/WordPress/wordpress-develop/blob/master/src/wp-admin/about.php#L30-L38

The text was changed for 5.2 in commit Changeset#45271, and the placeholder and translator comment introduced in commit Changeset#45338.

#9 @ocean90
9 months ago

  • Resolution changed from fixed to duplicate

Duplicate of #46408.

Note: See TracTickets for help on using tickets.