WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#46799 closed defect (bug) (duplicate)

PHP warning class-wp-query.php

Reported by: chargeup Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Query Keywords:
Focuses: Cc:

Description

I've been getting a PHP warning on most of my sites since the latest WordPress 5.1.1 update. It doesn't appear to be caused by a plugin or theme. I am getting the errors from my error logs and it happens frequently just about everyday.

Everything is up-to-date. I am on the newest version of WordPress and am running PHP 7.2.

Here is the error I'm getting on every site regardless of theme or plugins used.

PHP Warning: trim() expects parameter 1 to be string, array given in /home/.../public_html/wp-includes/class-wp-query.php on line 755

Change History (4)

#1 @chargeup
3 years ago

Here is the line of code in questions on line 755:

$qv['name']     = trim( $qv['name'] );
Last edited 3 years ago by SergeyBiryukov (previous) (diff)

#2 follow-up: @desrosj
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.1 deleted

Duplicate of #17737.

Hi @chargeup,

Welcome to Trac! There is already an issue tracking this.

#3 in reply to: ↑ 2 @chargeup
3 years ago

Thanks for the quick response. What action do I need to take to fix this or is this something that will be fixed in the next WordPress release?

Replying to desrosj:

Duplicate of #17737.

Hi @chargeup,

Welcome to Trac! There is already an issue tracking this.

#4 @SergeyBiryukov
3 years ago

  • Component changed from General to Query
Note: See TracTickets for help on using tickets.