WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 3 months ago

Last modified 3 months ago

#46805 closed task (blessed) (fixed)

Upgrade to Twemoji 12.0

Reported by: superpoincare Owned by: pento
Milestone: 5.2 Priority: normal
Severity: normal Version: 5.1
Component: Emoji Keywords:
Focuses: Cc:

Description

Twemoji 12 has released: https://github.com/twitter/twemoji

and has new emoji from Emoji 12 released last month.

There's also a confirmed bug #46404 which needs to be fixed.

Also may I suggest loading the file wp-emoji-release.min.js using preload+async (one of the options suggested here: https://twitter.com/addyosmani/status/1098122582472212481)? I have noticed that browsers sometimes stall scripts with a defer tag and delay it much.

Change History (6)

#1 @superpoincare
4 months ago

  • Type changed from defect (bug) to enhancement

#2 @desrosj
4 months ago

  • Milestone changed from Awaiting Review to 5.2
  • Type changed from enhancement to task (blessed)

Thanks @superpoincare! I’m moving this into the 5.2 milestone for visibility and marking it as a task. I’ll let @pento determine if he’s comfortable upgrading this during the beta period since he is the component maintainer.

#3 @pento
3 months ago

  • Owner set to pento
  • Status changed from new to assigned

Yah, we can do this.

For the stalling issue, this may be because defer is not obeyed in Chrome when the page is served as XHTML.

#4 @pento
3 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 45134:

Emoji: Update Twemoji to version 12.0.0.

Props pento, superpoincare.
Fixes #46404, #46805.

#5 @earnjam
3 months ago

Was compiling some last minute dev notes and noticed that they released a version 12.0.1 two days ago with some additional emojis that were missed in 12.0.0.

https://github.com/twitter/twemoji/releases/tag/v12.0.1

@pento Do we want to try to get that in before the RC later today?

#6 @pento
3 months ago

In 45240:

Emoji: Upgrade Twemoji to 12.0.1.

As this point release doesn't modify any images, only adding a few missing ones, we don't need to change the CDN location.

Props earnjam.
Fixes #46805.

Note: See TracTickets for help on using tickets.