WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 6 months ago

Last modified 3 months ago

#46814 closed defect (bug) (fixed)

Site Health reports "A plugin has prevented updates" when no plugins are activated.

Reported by: axaak Owned by: SergeyBiryukov
Milestone: 5.2 Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: site-health has-patch commit
Focuses: Cc:

Description

*Steps to re-create*

Version: WordPress 5.2-beta1-45112
Deactivate all plugins
Run site check get message

A plugin has prevented updates by disabling wp_version_check().

but no plugins are activated. The site cannot be updated but not because of plugins. Better wording might be "Automatic updates are disabled"

Attachments (2)

snapshot3.png (123.1 KB) - added by axaak 6 months ago.
A plugin has prevented message
46814.patch (844 bytes) - added by Clorith 6 months ago.

Download all attachments as: .zip

Change History (7)

@axaak
6 months ago

A plugin has prevented message

#1 @knutsp
6 months ago

  • Component changed from General to Administration
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version set to trunk

Duplicate of #46616.

Hello @axaak

Welcome back and thanks for the report.

It seems, however, this has already been fixed.

#2 @Clorith
6 months ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 5.2
  • Resolution duplicate deleted
  • Status changed from closed to reopened

This appears to be a result of the test site running on https without a valid certificate.

We do a call back to the page to test for the wp_version_check filter, and the wp_remote_get call will fail with an invalid certificate, causing it to show an error state.

Sounds like it would be more valid to show a warning state if we can't load the result page.

@Clorith
6 months ago

#3 @Clorith
6 months ago

  • Keywords has-patch commit added; needs-patch removed

46814.patch applies a check for errors in the request, and marks it accordingly if it's a test failure, or an incomplete test.

This means if the only thing we can't do is test for this filter, due to a broken certificate or similar, it will get a recommended status with an appropriate associated text.

#4 @SergeyBiryukov
6 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from reopened to closed

In 45118:

Site Health: Display a correct error message for a failing request in wp_version_check() test.

Props Clorith, axaak.
Fixes #46814.

#5 @spacedmonkey
3 months ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.