WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

Last modified 7 months ago

#46819 closed defect (bug) (fixed)

Remove the Privacy Bubble as it's not dismissible and obtrusive

Reported by: garrett-eclipse Owned by: pento
Milestone: 5.2 Priority: normal
Severity: normal Version: 5.2
Component: Privacy Keywords: has-patch commit
Focuses: ui, administration Cc:
PR Number:

Description

Hello,

This ticket is to quickly expedite the removal of the Privacy Policy guide updated bubble on the Settings & Settings > Privacy menu items.

This is branching from #44669 to address the comment by @pento here;
https://core.trac.wordpress.org/ticket/44669#comment:15

In order to expedite the first step of removing the Privacy bubble this ticket was created which will be updated shortly with a working patch.

Further work on notifying admins of privacy policy changes will be addressed in #44669 and #44538

Attachments (2)

46819.diff (2.0 KB) - added by garrett-eclipse 7 months ago.
Patch to remove the Privacy bubble
46819.2.diff (2.4 KB) - added by garrett-eclipse 7 months ago.
Removed the bubble code from 'Settings'

Download all attachments as: .zip

Change History (10)

@garrett-eclipse
7 months ago

Patch to remove the Privacy bubble

#1 @garrett-eclipse
7 months ago

  • Keywords has-patch needs-testing added
  • Owner set to garrett-eclipse
  • Status changed from new to accepted

Uploaded initial patch to remove the Privacy bubble.

#2 @garrett-eclipse
7 months ago

  • Milestone changed from Awaiting Review to 5.2

#3 @xkon
7 months ago

@garrett-eclipse thanks for the patch!

I've just skimmed through the code and noticed that the the $change_notice should also be removed from the Settings menu as well. For a little bit more help & in depth look of what was changed when these bubbles where introduced you can review the commit at https://core.trac.wordpress.org/changeset/43223 .

Not sure if we want to keep all the other checks and values as well but most likely they'll be handy for the notice I suppose.

@garrett-eclipse
7 months ago

Removed the bubble code from 'Settings'

#4 @garrett-eclipse
7 months ago

Thanks for the catch @xkon I've removed the code for the 'Settings' as well in 46819.2.diff. I've left the other checks so they can be leveraged when re-introducing the notice. Cheers

#5 @ianbelanger
7 months ago

  • Keywords commit added; needs-testing removed

Just tested 46819.2.diff against trunk and it works as intended. Marking for commit

#6 @pento
7 months ago

  • Owner changed from garrett-eclipse to pento

#7 @pento
7 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 45142:

Privacy: Remove the privacy changes bubble.

This notification was a little too intrustive, and suffered from being difficult to dismiss.

Props garrett-eclipse, xkon, ianbelanger.
Fixes #46819.

#8 @williampatton
7 months ago

#47006 was marked as a duplicate.

Note: See TracTickets for help on using tickets.