WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

#46916 closed defect (bug) (duplicate)

i18n: Merge similar translation strings (wp-admin/users.php)

Reported by: ramiy Owned by: pento
Milestone: Priority: normal
Severity: normal Version:
Component: Users Keywords: has-screenshots has-patch
Focuses: administration Cc:

Description

See the attached patch.

Attachments (2)

46916.png (13.2 KB) - added by ramiy 3 months ago.
46916.patch (1.3 KB) - added by ramiy 3 months ago.

Download all attachments as: .zip

Change History (5)

@ramiy
3 months ago

@ramiy
3 months ago

#1 @ramiy
3 months ago

  • Keywords has-screenshots has-patch added

This patch splitting the string to two strings. It simplifies the code and making the translations much easier.

This ticket was mentioned in Slack in #core by ramiy. View the logs.


3 months ago

#3 @SergeyBiryukov
3 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Thanks for the patch! There are two more similar strings:

User has been added to your site.
User has been added to your site. <a href="%s">Edit user</a>

User added.
User added. <a href="%s">Edit user</a>

That said, I'd prefer to leave them all as is.

In Russian, Edit user is translated simply as Edit in this context, to avoid repetition. This would be impossible if the strings are separated. The current strings seem simple enough to translate.

This appears to be a duplicate of #35746.

Note: See TracTickets for help on using tickets.