WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 6 months ago

#46926 closed defect (bug) (duplicate)

May be a bug of comment_form_title() function?

Reported by: syshut Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords:
Focuses: Cc:
PR Number:

Description

Hi,

In comments.php template, I use comment_form() function to output the commenting form:

<?php
        $comments_args = array(
                'title_reply_to'       => 'Leave a Reply to %s',
        );
        comment_form( $comments_args );

But when I click on the Reply button on each comment, the reply title of the commenting form is not what I’ve set, but still ‘Leave a Reply’.

I checked out the default themes with my site, and some other wordpress websites whether with default themes or with self-made themes, they were all like this.

I figured out it may be the bug of the comment_form_title() function, so please check it out.

Example link: http://ottopress.com/2013/im-not-a-fan-of-orange/

Thank you!

Attachments (1)

2333.png (25.9 KB) - added by syshut 8 months ago.

Download all attachments as: .zip

Change History (3)

@syshut
8 months ago

#1 @SergeyBiryukov
8 months ago

  • Component changed from General to Comments

#2 @earnjam
6 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 5.1.1 deleted

Hi @syshut and welcome to WordPress Trac!

This is a duplicate of #35650. There are some more details about why this occurs on that ticket and how it could potentially be fixed. I'm going to close this to continue the discussion there.

Note: See TracTickets for help on using tickets.