WordPress.org

Make WordPress Core

Opened 4 months ago

Last modified 3 weeks ago

#46981 closed defect (bug)

Bundled themes should pass version to wp_enqueue_script() to ensure proper cache busting — at Version 2

Reported by: dswebsme Owned by: dswebsme
Milestone: 5.3 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch needs-testing
Focuses: Cc:

Description (last modified by dswebsme)

Bundled themes should pass the current theme version ($ver parameter) to wp_enqueue_script() to ensure theme stylesheets properly bypass cache after being updated.

Original DEV discussion (related to stylesheets) took place here: #39997

In this discussion script enqueues were mentioned briefly but could definitely benefit from cache busting as well.

This affects themes twentyten - twentyseventeen. Bundled theme twentynineteen already passes a dynamic $ver parameter.

Change History (2)

#1 @dswebsme
4 months ago

  • Description modified (diff)
  • Owner set to dswebsme
  • Status changed from new to assigned

#2 @dswebsme
4 months ago

  • Description modified (diff)
Note: See TracTickets for help on using tickets.