WordPress.org

Make WordPress Core

Opened 20 months ago

Closed 3 months ago

Last modified 3 months ago

#46985 closed enhancement (duplicate)

Evaluate removing Thickbox

Reported by: desrosj Owned by:
Milestone: Priority: low
Severity: normal Version:
Component: External Libraries Keywords:
Focuses: accessibility, javascript, administration Cc:

Description

Thickbox is an outdated, unmaintained JavaScript library (last updated in 2007) that has been superseded by other, more modern and maintained options in the last 12 years.

After a few discussions with @joemcgill, this ticket is being opened to audit the current usage in Core, to discuss alternatives, and to discuss potentially removing the library entirely.

On initial scan, the most prominent usage of Thickbox is on the "Plugins" and "Updates" screens powering the "View Details" and "View version details" overlays.

Change History (11)

#1 @Clorith
20 months ago

We should also evaluate use in plugins and themes for this, I believe we discussed this 2ish years ago and diacovered a not insubstantial amount of plugins relied on it at that time, so this should be re-checked now.

#2 @desrosj
20 months ago

Thanks for adding that, @Clorith! I forgot to add that to my description. Completely agree. This is what I had in mind:

  1. Audit use in Core.
  2. Replace remaining usages (if there is a decision to proceed).
  3. Evaluate remaining use in the wild (plugins, themes, custom code).
  4. Present developers with better alternatives and educate.
  5. Remove form Core entirely or switch to enqueueing from a CDN (similar to Scriptaculous and Prototype in Core now).

#3 @afercia
20 months ago

  • Focuses accessibility added

Any new modal implementation should also be accessible :)

#4 @johnbillion
20 months ago

  • Focuses javascript added
  • Priority changed from normal to low
  • Type changed from defect (bug) to enhancement

I think you'll find a very large number of plugins and themes using Thickbox.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


19 months ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


19 months ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


17 months ago

This ticket was mentioned in Slack in #accessibility by audrasjb. View the logs.


16 months ago

This ticket was mentioned in Slack in #accessibility by azhiyadev. View the logs.


3 months ago

#10 @desrosj
3 months ago

  • Keywords 2nd-opinion early removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm going to close this out as a duplicate of #10955 as there is more discussion there.

#11 @afercia
3 months ago

Thanks, I will add the accessibility focu to #10955 :)

Note: See TracTickets for help on using tickets.