WordPress.org

Make WordPress Core

#46998 closed defect (bug) (wontfix)

(Mobile) Admin Dashboard-Link remains focused/active

Reported by: akuczera Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Administration Keywords:
Focuses: ui, accessibility Cc:

Description

I have noticed the "Dashboard" menuitem/link on mobile devices remains focused/active after visiting other dashboard-sites. Both (the current menuitem and dashboard) are active/focused at the same time after opening the menu (hamburger) again.

Change History (10)

#1 @desrosj
10 months ago

  • Keywords reporter-feedback needs-screenshots added

Hi @akuczera,

Welcome to Trac! Thank you for this bug report.

Are you able to provide screenshots to illustrate this better?

#2 @desrosj
10 months ago

  • Component changed from General to Administration

#3 @akuczera
10 months ago

Standard Dashboard:
"Dashboard" icon and label remain highlighted in blue.

https://i.imgur.com/jwiZBJp.jpg

Last edited 10 months ago by akuczera (previous) (diff)

#4 follow-up: @afercia
10 months ago

  • Keywords close added

This is because focus is set on the first menu item, and for good reasons. See [27011] / #26639.

#5 in reply to: ↑ 4 @akuczera
10 months ago

Replying to afercia:

This is because focus is set on the first menu item, and for good reasons. See [27011] / #26639.

So why not just focus the menu-link for the active window? If you're using a screenreader you want to know where you are, don't you?
Anyway thank you for the reply, i will "fix" it for my needs.

#6 @SergeyBiryukov
10 months ago

  • Focuses accessibility added

#7 @SergeyBiryukov
10 months ago

  • Focuses ui added

#8 @afercia
10 months ago

  • Keywords reporter-feedback needs-screenshots removed

So why not just focus the menu-link for the active window? If you're using a screenreader you want to know where you are, don't you?

This is not just about screen reader users. It's for all keyboard users. The toggle button and the navigation menu are far from each other in the source. When activating the toggle, there would be the need to tab several times to get to the menu: this is why focus is moved to the menu but it can't be moved to the active item skipping all the previous items.

Ideally, the toggle button should be placed immediately before the navigation menu: this way, there wouldn't be the need to move focus at all, as the menu would be the following focusable thing in the native tab order. However, this would require some big refactoring. Also, visual order should match the DOM order so I'm not sure it can be fixed easily. Overall, I'm not sure there's actually something to "fix": this is not a visual glitch, it's just the intended indication of focus. Worth also noting #28599 (long standing ticket) proposes to make the focus indication on the menu even more prominent.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


10 months ago

#10 @afercia
10 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version 5.1.1 deleted

Discussed during today's accessibility bug scrub and agreed to close this issue as this is the intended behavior. As mentioned in a previous comment, the only way to avoid to move focus in the first place would be a major refactoring of the admin menu.

Note: See TracTickets for help on using tickets.