WordPress.org

Make WordPress Core

Opened 8 months ago

Closed 8 months ago

Last modified 8 months ago

#47007 closed defect (bug) (invalid)

object-cache.php loaded before must-use plugins

Reported by: viktorix Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.1.1
Component: Plugins Keywords: dev-feedback
Focuses: Cc:
PR Number:

Description

I noticed that constants defined in must-use plugin were undefined if used in object-cache.php dropin plugin. Looking at wp-includes/load.php the object-cache.php check is loaded prior to must-use plugins.

I assumed must-use plugins are always loaded before all other plugins. If this is not a bug and it functions as intended, updating documentation would be helpful to note that must-use plugins are loaded after dropin plugins.
https://codex.wordpress.org/Must_Use_Plugins#Features

Thanks!

Change History (2)

#1 @johnbillion
8 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the report @viktorix.

This is indeed intended behaviour, as dropins control some of the low level behaviour of WordPress that loads much earlier than plugins do.

The Codex is a wiki, therefore that page can be edited by anyone with a wordpress.org user account.

#2 @viktorix
8 months ago

Thanks.

Note: See TracTickets for help on using tickets.