WordPress.org

Make WordPress Core

Opened 6 months ago

Closed 12 days ago

#47010 closed defect (bug) (fixed)

Clumsy horizontal scroll when menu is open on mobile

Reported by: promz Owned by: SergeyBiryukov
Milestone: 5.3 Priority: normal
Severity: normal Version:
Component: Administration Keywords: commit has-patch
Focuses: ui, administration Cc:
PR Number:

Description

Steps to reproduce:

  1. Open WP Admin in mobile
  2. Click on the burger menu icon, this will open the menu
  3. Try to horizontally scroll to bottom-left

Result: The screen should scroll to left as shown in the attached GIF.

Tested on: Chrome on Mac and Chrome on Android (Honor Play)

Attachments (2)

wp problem.gif (4.1 MB) - added by promz 6 months ago.
Horizontal scroll problem
47010.diff (376 bytes) - added by promz 6 months ago.
This fixes the problem and doesn't caused any problems as far as I have tested.

Change History (11)

@promz
6 months ago

Horizontal scroll problem

#1 @promz
6 months ago

  • Focuses ui administration added

I realized that changing the position of#adminmenuback from Absolute to Fixed fixes the problem.

.auto-fold #adminmenuback {
	position: fixed;
}

#2 @man4toman
6 months ago

Hi @promz
I check it on latest version of Firefox and Opera with Windows OS, I can't reproduce the problem.

#3 @promz
6 months ago

@man4toman you should probably check on a real device. Here are the screencasts:

Android: https://drive.google.com/file/d/16VNImnh2g9Ncg7cXU8XvwabGcKJEtzDS/view?usp=sharing

iPhone (horizontal scroll problem is not there but there is another scrolling problem):
https://drive.google.com/file/d/1NOlWNZmzTgnB2vXzlfnetT1ExpYQLmbM/view?usp=sharing

The problem is with the older WordPress versions too.

@promz
6 months ago

This fixes the problem and doesn't caused any problems as far as I have tested.

#4 @SergeyBiryukov
6 months ago

  • Milestone changed from Awaiting Review to 5.3
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing
  • Version trunk deleted

Hi @promz, welcome to WordPress Trac! Thanks for the report.

I'm removing the trunk version, as this doesn't seem to be a regression in 5.2.

This ticket was mentioned in Slack in #core by david.baumwald. View the logs.


4 weeks ago

#6 @antpb
4 weeks ago

  • Keywords commit has-patch added

Hi @SergeyBiryukov ! This patch looks good in my testing and still applies clean. It is also in line with the focus of 5.3 on UI improvements.

If you're good with it, I can commit. :)

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


13 days ago

#8 @mikeschroder
13 days ago

We chatted about this ticket in today's triage.

@antpb I think that unless @SergeyBiryukov has any hesitations here, your +1 along with previous testing seems good to me.

#9 @antpb
12 days ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 46460:

Administration: Prevents horizontal scroll jumping around while admin menu is open.

This sets the #adminmenuback position CSS property to fixed.

Props promz, man4toman.
Fixes #47010.

Note: See TracTickets for help on using tickets.