WordPress.org

Make WordPress Core

Opened 16 months ago

Closed 5 months ago

#47019 closed defect (bug) (fixed)

Twenty Sixteen: Text color setting in pullquote block not applied

Reported by: kokkieh Owned by: ianbelanger
Milestone: 5.4 Priority: normal
Severity: normal Version: 5.0
Component: Bundled Theme Keywords: good-first-bug has-patch
Focuses: Cc:

Description

Text color settings in the pull quote block are not being applied.

To replicate:

  1. With Twenty Sixteen active, create a new post in the block editor
  2. Add a Pullquote block
  3. Add some text and try adjusting the color settings

Result:

The border color is applied, but the text color is not applied in either the editor or the published post.

The source code for the post does show a class for the applied color:

<figure class="wp-block-pullquote" style="border-color:#ff675f"><blockquote class="has-text-color has-bright-blue-color"><p>This is a quote</p><cite>by me<br></cite></blockquote></figure>

But looking in the inspector it seems the color is instead being applied from the blocks.css file, line 170:

.wp-block-pullquote p {
	color: #686868;
	font-size: 19px;
	font-size: 1.1875rem;
}

Reported by a WordPress.com user in the forums, but confirmed on a self-hosted installation as well. Also tested with no plugins active at all to rule out possible conflicts.

Attachments (3)

47019.diff (1.0 KB) - added by mukesh27 16 months ago.
Patch.
47019.2.diff (470 bytes) - added by khushbu19 15 months ago.
47019.3.diff (1.1 KB) - added by ianbelanger 6 months ago.
Updates patch with with style fix for pullquote, border-left was not showing on front end

Download all attachments as: .zip

Change History (22)

#1 @desrosj
16 months ago

  • Keywords needs-patch good-first-bug added
  • Milestone changed from Awaiting Review to 5.3
  • Version changed from 5.1.1 to 5.0

Thanks, @kokkieh! I am also able to reproduce this. Looks like the text color has never worked correctly in Twenty Sixeteen.

@mukesh27
16 months ago

Patch.

#2 @mukesh27
16 months ago

  • Keywords needs-testing added

#3 @mukesh27
16 months ago

  • Keywords has-patch added; needs-patch removed

@khushbu19
15 months ago

#4 @disillusia
15 months ago

  • Keywords 2nd-opinion added

Hello guys!

Tested both 47019 and 47019.2.

47019 looks good to me; it seems to solve the issue on both the editor and frontend. On the other hand, 47019.2 doesn't seem to work well.

First time participating/contributing so I hope I'm doing it correctly! Looking forward to help out more.

This ticket was mentioned in Slack in #core by sergey. View the logs.


15 months ago

#6 @aliveic
14 months ago

Hi all.

I also tested the 47019 patch and I confirm that it works on my freshly installed latest build.

This is my first contribution. Hope it's helpful.

This ticket was mentioned in Slack in #core by desrosj. View the logs.


14 months ago

#8 @desrosj
14 months ago

  • Keywords 2nd-opinion removed

#9 @SergeyBiryukov
14 months ago

  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#10 @abrightclearweb
11 months ago

47019 works for me too.

This ticket was mentioned in Slack in #core by marybaum. View the logs.


10 months ago

#12 @davidbaumwald
10 months ago

  • Keywords commit added; needs-testing removed

The most recent patch applies cleanly to trunk, and the testing appears to confirm a resolution. Marking this one for commit.

This ticket was mentioned in Slack in #core by ianbelanger. View the logs.


10 months ago

#14 @SergeyBiryukov
10 months ago

  • Milestone changed from 5.3 to 5.4

I might be doing something wrong, but for some reason 47019.diff did not resolve the issue in my testing. I did, however, notice that other bundled themes appear to have the same issue.

Moving to 5.4 to handle this consistently across all bundled themes.

Last edited 10 months ago by SergeyBiryukov (previous) (diff)

#15 @ianbelanger
10 months ago

  • Keywords needs-testing added; commit removed

@ianbelanger
6 months ago

Updates patch with with style fix for pullquote, border-left was not showing on front end

#16 @ianbelanger
6 months ago

  • Keywords commit added; needs-testing removed
  • Owner changed from SergeyBiryukov to ianbelanger

Reviewing for commit.

#17 @ianbelanger
6 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 47273:

Bundled Themes: Twenty Sixteen text color setting in pullquote block not applied.

Fixes the pullquote color setting by moving color from blockquote p to blockquote. Also adds the border-left to the front-end stylesheet to match the editor. Also adds styles for rtl pullquote.

Props kokkieh, desrosj, mukesh27, khushbu19, disillusia, aliveic, abrightclearweb, SergeyBiryukov.
Fixes #47019.

#18 @ianbelanger
6 months ago

  • Keywords fixed-major added
  • Milestone changed from 5.4 to 5.3.3
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport.

#19 @audrasjb
5 months ago

  • Keywords commit fixed-major removed
  • Milestone changed from 5.3.3 to 5.4
  • Resolution set to fixed
  • Status changed from reopened to closed

Moving 5.3.3 Bundled Themes tickets back to milestone 5.4 as RC1 is approaching.
Please don't move them back to 5.3.3 :-)

Note: See TracTickets for help on using tickets.