WordPress.org

Make WordPress Core

Opened 3 months ago

Closed 3 months ago

Last modified 4 weeks ago

#47027 closed enhancement (duplicate)

Add new capability to view site health

Reported by: spacedmonkey Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: needs-patch site-health servehappy
Focuses: Cc:

Description

Currently the site health screen is only viewable if the users has the install_plugins capability. However, if you have disabled DISALLOW_FILE_MODS or you are not a super admin on multisite, you are unable to see the site health. A new capability could be added called view_site_health that maps to install_plugins by default could be added. This would allow developers to add the capability without re-enabling installing plugins.

Attachments (1)

47027.diff (2.9 KB) - added by spacedmonkey 3 months ago.

Download all attachments as: .zip

Change History (9)

This ticket was mentioned in Slack in #core-php by spacedmonkey. View the logs.


3 months ago

#2 @spacedmonkey
3 months ago

  • Keywords site-health servehappy added; sitehealth removed

#3 @jorbin
3 months ago

  • Milestone changed from Awaiting Review to 5.2

Moving to 5.2 for visibility and discussion as this is a new feature, not as a commitment.

#4 @SergeyBiryukov
3 months ago

  • Component changed from General to Administration

#5 @azaozz
3 months ago

  • Milestone 5.2 deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Frankly I'm not sure how useful this will be in core. A specific capability can certainly be added by a plugin to cover cases where there are a lot of people administering a (single) site, and the "site admin" role is split up in several "levels". However thinking this is rather rare and leaving it to be implemented by a plugin is sufficient.

Closing as "worksforme" for now. Please feel free to reopen with specific, somewhat common user cases.

@spacedmonkey
3 months ago

#6 @ocean90
3 months ago

  • Resolution changed from worksforme to duplicate

Duplicate of #46957.

#7 @spacedmonkey
3 months ago

Moving the chat on this topic to #46957 where I have re-uploaded the patch.

#8 @spacedmonkey
4 weeks ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.