WordPress.org

Make WordPress Core

Opened 3 years ago

Last modified 4 months ago

#47130 reopened defect (bug)

Drop files to upload is also available except Upload Media tab

Reported by: malavvasita Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version: 5.1.1
Component: Media Keywords: needs-patch has-screenshots
Focuses: accessibility, javascript, administration Cc:

Description

Howdy Developers,

As per my understanding, Drop files to upload feature should be enabled during Upload media only.

Instead of that, I have noticed that whenever Crop Image or any other popup for media is open, then Drop files to upload is still there.

Attachments (1)

Customize WebSite – Just another WordPress site.png (46.7 KB) - added by malavvasita 3 years ago.

Download all attachments as: .zip

Change History (18)

#1 @malavvasita
3 years ago

  • Keywords has-screenshots added

#2 @malavvasita
3 years ago

Hello @afercia,

I dont know if you are the right person I have tagged or not. But in many tickets, I have seen you. So I am mentioning you in this ticket.

Can you or any other person please give any suggestion feedback on this ticket?

Thank you.

#3 @afercia
3 years ago

@malavvasita thank you for the ticket and the ping.

I was able to reproduce that drag-and-drop is still active on media views that are not specific to uploading. I guess the Media component maintainers are the best persons for some feedback :)

For more information on the Core components and the various groups of maintainers, please see https://make.wordpress.org/core/components/

#4 @malavvasita
3 years ago

Thank you @afercia for follow up and lead.

Hey @mikeschroder,

I am able to reproduce this issue. And if it is minor one, can it be ready for next release?
Please give your valuable feedback on this issue.

Thank you in advance.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


2 years ago

#6 @afercia
2 years ago

  • Milestone changed from Awaiting Review to Future Release

Discussed during today's accessibility bug scrub and agreed this should be improved. Not sure it's an accessibility priority, sounds more like something for the Media team :)

#7 @malavvasita
10 months ago

Any plans to include this in a future release? @afercia
Or if you can tag any Media Team member? so that this can be improved.

This ticket was mentioned in Slack in #core-media by malavvasita. View the logs.


6 months ago

#9 @malavvasita
6 months ago

@antpb @joedolson

By any chance, if you come across this ticket, can you please validate and want it to be in the next release of WordPress?

Thanks.

#10 @malavvasita
5 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #53469.

#11 @desrosj
5 months ago

#53469 was marked as a duplicate.

#12 @desrosj
5 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I'm reopening this ticket. #53469 is a duplicate report of the same issue reported here.

#13 @sabernhardt
5 months ago

  • Focuses javascript added

#14 @malavvasita
4 months ago

@desrosj

Hope you are doing good.

WordPress 5.8 is now released. I have checked it out and looks great to me. Kudos to the team and contributors.

Unfortunately, I am able to produce this issue and the fix is not available yet. Can you please set the Next Release Milestone on this issue please?

Thanks.

This ticket was mentioned in Slack in #core-media by malavvasita. View the logs.


4 months ago

This ticket was mentioned in Slack in #core-media by malavvasita. View the logs.


4 months ago

#17 @antpb
4 months ago

Thanks for this report @malavvasita! Upon discussion in the Media component meeting today we determined that, while not perfect, the ability to upload is currently not destructive to the flow of cropping media or doing other tasks in the Media modal. We agreed that it would be a great refinement to not allow drag and drop to activate in certain views like crop.

I think it would be fair to get into 5.9 but only if a patch is submitted and tested before then. At the moment, it was not seen as the highest priority fix for Media which means there is currently no one available to own this ticket.

This is not to say that we cannot include it in 5.9! If you or someone you know would like to submit a patch, I'd be happy to review and work towards including it in 5.9. :)

Note: See TracTickets for help on using tickets.