WordPress.org

Make WordPress Core

Opened 5 months ago

Closed 6 weeks ago

Last modified 4 weeks ago

#47135 closed defect (bug) (duplicate)

Drag and drop functionality unavailable to keyboard or touchscreen

Reported by: anevins Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Media Keywords: has-screenshots needs-patch wpcampus-report
Focuses: ui, accessibility Cc:
PR Number:

Description

Moved from the WPCampus accessibility report issues on GitHub, see https://github.com/WordPress/gutenberg/issues/15316

  • Severity:
    • Low
  • Affected Populations:
    • Blind
    • Motor Impaired
  • Platform(s):
    • All / Universal
  • Components affected:
    • Edit Media

Issue description
The Edit Media interface* includes the ability to re-arrange the boxes by
drag and drop, however this can only be achieved by mouse users, since
the functionality does not support touch or keyboard users.

Users of touchscreens and keyboards cannot re-order the boxes. Speech
recognition users may be able to if they can manipulate the mouse with
speech (such as using Mouse Move), however this is onerous and
difficult.

Remediation Guidance
Allow keyboard and touchscreen users the ability to re-arrange the
boxes. This can either be done with dedicated buttons, such as are used
within Gutenberg for moving Blocks; or it could be done by extending
drag and drop support to keyboard and touch users (a good example of
which is dragondrop: https://schne324.github.io/dragon-drop/demo/).

Relevant standards

Note: This issue may be a duplicate with other existing accessibility-related bugs in this project. This issue comes from the Gutenberg accessibility audit, performed by Tenon and funded by WP Campus. This issue is GUT-80 in Tenon's report

*Original issue description and screenshot are available at page 142 of the complete technical report PDF. However, the screenshot appears to be related to the edit post screen in the classic editor.
https://github.com/WordPress/gutenberg/issues/15316#issuecomment-489460963

Attachments (1)

57182776-395bb680-6e58-11e9-9962-4722c9f98625.png (76.9 KB) - added by anevins 5 months ago.

Download all attachments as: .zip

Change History (11)

#1 @afercia
5 months ago

  • Milestone changed from Awaiting Review to 5.3

#2 @afercia
4 months ago

Previously: #39074.

#3 @karmatosed
2 months ago

  • Keywords needs-design-feedback added

#4 @karmatosed
2 months ago

  • Keywords needs-design-feedback removed

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


2 months ago

This ticket was mentioned in Slack in #core-media by anevins. View the logs.


7 weeks ago

This ticket was mentioned in Slack in #core-media by anevins. View the logs.


6 weeks ago

#8 @antpb
6 weeks ago

  • Milestone 5.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket was discussed in the recent media meeting and it was determined that the scope of this issue is wider than the edit media page. While this page certainly has the issue of no clear way to move boxes, the problem exists with every form of meta boxes.

There is an existing issue that more globally addresses this problem here: https://core.trac.wordpress.org/ticket/39074

The information in this media focused ticket is more detailed with suggestions to solving this. I’ll copy over the important bits and close this out as duplicate of #39074.

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


6 weeks ago

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


4 weeks ago

Note: See TracTickets for help on using tickets.