WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 9 years ago

#4714 closed defect (bug) (invalid)

category feeds are incorrect

Reported by: peterryan Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

My wordpress install returns the wrong category feeds. For example if I go here:

http://www.peterryan.net/category/geek/feed/
and then
http://www.peterryan.net/category/cooking/feed/

I get the correct feed for the 'geek' category but for 'cooking' I get the 'geek' feed.

I am using a Wordpress generated htaccess. This problem only exists when i use pretty permalinks.

The problem occurs in both the default and classic themes.

Change History (11)

#1 @markjaquith
12 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce locally, and when I visit your cooking feed as linked above, I see three entries about cooking. Figured it out?

#2 @Otto42
12 years ago

  • Summary changed from trac category feeds are incorrect to category feeds are incorrect

I can reproduce his problem, using his site. He's got it backwards though, both his links appear to give his "cooking" feed.

http://www.peterryan.net/category/cooking/ has 3 entries.
http://www.peterryan.net/category/geek/ has 4 entries.

http://www.peterryan.net/category/cooking/feed/ and
http://www.peterryan.net/category/geek/feed/ both appear to give the feed for the cooking category. Although it's not consistent. Refreshing sometimes gives the correct information.

I cannot reproduce the problem on my own site, so I'd suggest that he disable any/all plugins and see if the problem goes away.

#3 @peterryan
12 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

i have disabled all the plugins i had active (google analytics, askimet, and a google code syntax highlighter plugin).

the problem is sometimes reversed - it seems like something (again i don't know what it could be apache2, php5, or wordpress) is caching a result and it eventually times out.

the problem also occurs sometimes after i load a feed and try and go to what should be an HTML reponse and the result is XML.

right now (this is inconsistent) if I go to

http://www.peterryan.net/category/geek/feed/ i see the correct feed
and then if i go to
http://www.peterryan.net/category/geek i see the feed again where I really should see the html archive of the category.

something is wrong..I am not sure exactly what. if there is somewhere I could be looking or if there is a way (I am not familiar with php aside from it's most basic uses) I can send a better trace of what is going on please let me know.

#4 @Otto42
12 years ago

The problem is not limited to your category feeds. When I hit http://www.peterryan.net/feed/ I also sometimes get the category feed instead.

I think something on your webserver is doing some kind of weird caching. Ask your host if there's any kind of caching enabled on Apache or PHP or what have you.

#5 @leonid
12 years ago

One of the things to check is free disk space on that server. I remember having a similar problem long time ago, and there was an almost full hard disk. Cleaning it a bit solved the issue.

#6 @peterryan
12 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

well i am doing all the hosting. i disabled mod_cache and mod_disk_cache, cleared /var/apache2/mod_disk_cache just in case, and cleared my browser cache the feeds worked again. i guess this means that mod_rewrite executes before mod_cache (which is causing a caching key conflict). I am not sure if this is something that should be resovled by by debian etch (for their apache config), mod_cache/mod_rewrite (for the order the execute), or myself (for something i did that screwed up the order, or the htaccess rewrite rules that wordpress generates are somehow causing the cache key conflict.

thanks for the help.

#7 @santosj
12 years ago

Why don't you put mod_rewrite after mod_cache? If that indeed the problem?

#8 @Sewar
12 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

#9 @Sewar
12 years ago

  • Priority changed from high to normal
  • Resolution set to invalid
  • Status changed from reopened to closed
  • Version 2.2.1 deleted

#10 @maorb
9 years ago

  • Cc maorb added
  • Resolution invalid deleted
  • Status changed from closed to reopened

I encounter this problem too.
The issue is that the mod_cache is executed from the apache and the mod_rewrite is from within the Wordpress.
So, how can I put the mod_rewrite to active after the mod_cache ?

Any ideas?

#11 @dd32
9 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Trac is not a support forum. Please try either the WordPress support Forums or a Webserver-specific mailinglist/forum/support venue.

Note: See TracTickets for help on using tickets.