WordPress.org

Make WordPress Core

Opened 2 months ago

Closed 2 months ago

Last modified 4 weeks ago

#47204 closed defect (bug) (duplicate)

Site Health: not showing if DISALLOW_FILE_MODS is set to true

Reported by: palmiak Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: site-health
Focuses: Cc:

Description

Site Health page is not showing if you set "DISALLOW_FILE_MODS" to true (which is quite normal if you are using eg Bedrock - https://roots.io/bedrock/).

After some checking I've found the problem is related to this check:

current_user_can( 'install_plugins' )

I think that we can check for "manage_options" instead.

Attachments (1)

47204.diff (7.8 KB) - added by palmiak 2 months ago.
a patch for this bug

Download all attachments as: .zip

Change History (4)

@palmiak
2 months ago

a patch for this bug

#1 @TimothyBlynJacobs
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for the report @palmiak, this is being tracked in #46957

#2 @SergeyBiryukov
2 months ago

  • Component changed from General to Administration
  • Keywords site-health added

#3 @spacedmonkey
4 weeks ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.