WordPress.org

Make WordPress Core

Opened 4 months ago

Closed 4 months ago

Last modified 4 months ago

#47205 closed defect (bug) (fixed)

Typing spaces stops working after two soft line breaks in Chrome.

Reported by: parkcityj Owned by: azaozz
Milestone: 5.2.1 Priority: normal
Severity: normal Version: 5.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

When using the classic editor in the Chrome browser, an issue occurs where the space bar stops working when trying to add a new post.

To reproduce, using chrome:

  1. Create a new post.
  2. Type a few words in the visual editor, and hit shift+enter.
  3. Type a few more words, and hit shift+enter again.
  4. Type a few more words. Now all the words run together.

See video: https://d.pr/v/TYIC3x

Notes

  • Tested and reproduced the issue on 3 different sites (2 platforms), plus two local VVV installs.
  • Happens on WP 5.2, also observed in versions 5.1.x
  • Tested using Mac OS 10.14.4, Chrome Version 74.0.3729.131
  • This happens _only_ in the Chrome browser. It works fine on Firefox Dev (67.0b18) and Safari (Version 12.1)
  • This happens _only_ in the visual tab of the editor, not on the text side.
  • This happens only using the Classic editor, not Gutenberg.

cc: @davidsword who helped me test.. Thank you!

Change History (4)

#1 @azaozz
4 months ago

  • Milestone changed from Awaiting Review to 5.2.1

@parkcityj thanks for the great bug report and welcome to trac! :)

Confirmed, also happens on Windows and in all Chromium based browsers, and in the classic block in the block editor.

This seems to be a bug upstream that was fixed recently. To test:

We'll need to update TinyMCE to get it fixed. Setting this tentatively to 5.2.1. It's not a "huge" problem but very weirdly looking one, and in the most popular browser.

#2 @desrosj
4 months ago

I did some testing with the patch over on #47229 (which upgrades TinyMCE to 4.9.4) and can confirm the bug is fixed.

#3 @desrosj
4 months ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from new to closed

I am going to close this one out, as #47229 should fix this issue. @azaozz let's make sure @parkcityj gets props when [45316] is backported to 5.2 for the exceptionally detailed bug report!

#4 @azaozz
4 months ago

  • Owner set to azaozz

In 45343:

Update TinyMCE to 4.9.4. Changelog: https://github.com/tinymce/tinymce/blob/4.x/changelog.txt.

Props parkcityj, azaozz.
Merges [45316] to the 5.2 branch.
Fixes #47229 #47205.

Note: See TracTickets for help on using tickets.