WordPress.org

Make WordPress Core

#47206 closed feature request (duplicate)

SMTP Mail to be built into WP instead of PHP Mail

Reported by: subwebsites Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Mail Keywords:
Focuses: Cc:

Description

Hi,

Really simple question and I cant find any other place to ask this so may I ask for a response please.

Question is after all the updates in making WP awesome why the heck isn't SMTP built into WP instead of PHP Mail ?

PHP mail is crap and doesn't get emails to the correct location inboxes whereas everyone needs to install an SMTP plugin just to make emails works.

Or allow us to have an option of PHP or SMTP....

If PHP mail is crap and doesn't do what we need then why is it even there in the first place.

I would call this MAJOR as from what people say in other locations in social media and cannot get in contact with WP to mention this, we must be on a loosing streak if we cant get this heard!!!

Cheers

Change History (3)

#1 @SergeyBiryukov
17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Hi @subwebsites, welcome to WordPress Trac!

Thanks for the ticket, we're already tracking this enhancement in #29069.

#2 @subwebsites
17 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

How many years do we need to wait for this to happen... http://prntscr.com/nmmq92

https://www.youtube.com/watch?v=KliSG4bH0mA

The other threads never seem to resolve anything, it's like no-one cares

Last edited 17 months ago by subwebsites (previous) (diff)

#3 @knutsp
17 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #29069.

Still a duplicate. Please do not reopen without reasons for this not being a duplicate.Please voice your opinion on the original ticket, where the reasons for this being "maybelater" i stated. Closed tickets can be commented on.

Note: See TracTickets for help on using tickets.