WordPress.org

Make WordPress Core

Opened 7 months ago

Closed 7 months ago

#47208 closed defect (bug) (fixed)

wp_mail() docblock destcription has typo?

Reported by: seedsca Owned by: SergeyBiryukov
Milestone: 5.3 Priority: normal
Severity: minor Version:
Component: Mail Keywords: has-patch commit
Focuses: docs Cc:
PR Number:

Description

First from should be replaced with for.

It would then change the docblock to say:

Using the two ‘wp_mail_from’ and ‘wp_mail_from_name’ hooks allow for creating a from address like ‘Name email@…‘ when both are set. If just ‘wp_mail_from’ is set, then just the email address will be used with no name.

Attachments (1)

47208.diff (687 bytes) - added by seedsca 7 months ago.
Patch to clean up typo

Download all attachments as: .zip

Change History (9)

@seedsca
7 months ago

Patch to clean up typo

#1 @JeffPaul
7 months ago

  • Keywords needs-patch added
  • Severity changed from normal to minor

@seedsca nice catch! Are you able to work up a patch for that one?

#2 @seedsca
7 months ago

  • Keywords has-patch added; needs-patch removed

#3 @JeffPaul
7 months ago

  • Keywords commit added
  • Milestone changed from Awaiting Review to 5.2.1

@seedsca you win the race to initial response. This looks good to me, thanks!

#4 @seedsca
7 months ago

@JeffPaul I didn't know how to get the ticket number to add to the patch file :)
Thanks for your lightning quick response!

#5 @mukesh27
7 months ago

  • Focuses docs added

#6 @SergeyBiryukov
7 months ago

  • Component changed from General to Mail

#7 @SergeyBiryukov
7 months ago

  • Milestone changed from 5.2.1 to 5.3

Thanks for the ticket and the patch!

Going to move this to 5.3, as it's not a regression in 5.2 (the docs were added in [6637]), and we're trying to keep the number of changed files in minor releases to a minimum, due to reliability concerns for background updates.

#8 @SergeyBiryukov
7 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 45302:

Docs: Fix typo in wp_mail() description.

Props seedsca.
Fixes #47208.

Note: See TracTickets for help on using tickets.