WordPress.org

Make WordPress Core

#47220 closed enhancement (worksforme)

German Apostrophes (Enhancement suggestion)

Reported by: ibkarpowski Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Formatting Keywords:
Focuses: Cc:

Description

Hello dear developers,

I appreciate WordPress very much but I have a burning question: When I write a quote in my blog under German language profile, I get an English apostrophe, like this one -> ["]. German quote structure is very different. It starts with a low apostrophe, like this -> [„] and the quote ends with a high apostrophe, which seems to look the same, but it's not, it is also bended but the other way around than the English apostrophe -> [“]. Would it be possible to include these special punctuation marks within the Germanic WordPress core language files so it automatically converts it or is by design a plugin needed?

Thank you for your time.

Change History (2)

#1 @audrasjb
19 months ago

  • Component changed from Editor to I18N
  • Keywords close added

Hi @ibkarpowski, thanks for the ticket and welcome to WordPress Trac,

We have the same kind of issue in French with our own typographic quotes « … ».

However, this "issue" should not be solved on WordPress Core but with your own localized keyboard. For example, on MacOSX in French we are using ALT+7 or ALT+SHIFT+7 shortcuts to get opening and closing french quotes.

Cheers,
Jb

Last edited 19 months ago by audrasjb (previous) (diff)

#2 @ocean90
19 months ago

  • Component changed from I18N to Formatting
  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

WordPress already does this sort of formatting with the help of wptexturize(). The quotes are also translated in German.

Note: See TracTickets for help on using tickets.