WordPress.org

Make WordPress Core

#47289 closed defect (bug) (duplicate)

Modify `escape key` to` Esc key`

Reported by: tmatsuur Owned by: SergeyBiryukov
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Customize Keywords:
Focuses: Cc:

Description

The notation of Esc key is different in the following two sentences.

1./wp-includes/class-wp-customize-manager.php:5580

$section_description .= '<li id="editor-keyboard-trap-help-4">' . __( 'Screen reader users: when in forms mode, you may need to press the escape key twice.' ) . '</li>';

2./wp-includes/widgets/class-wp-widget-custom-html.php:322

$content .= '<li id="editor-keyboard-trap-help-4">' . __( 'Screen reader users: when in forms mode, you may need to press the Esc key twice.' ) . '</li>';

Shouldn't the sentence 1 be Esc key?

Attachments (1)

47289.diff (1.0 KB) - added by tmatsuur 11 months ago.

Download all attachments as: .zip

Change History (6)

@tmatsuur
11 months ago

#1 @SergeyBiryukov
11 months ago

  • Milestone changed from Awaiting Review to 5.3
  • Owner set to SergeyBiryukov
  • Status changed from new to reviewing

#2 follow-ups: @afercia
11 months ago

I'd rather change all of them to "Escape" as that's the name of the key. "Esc" is an abbreviation, much like "Ctrl" for "Control".

#3 in reply to: ↑ 2 @tmatsuur
11 months ago

Replying to afercia:

I'd rather change all of them to "Escape" as that's the name of the key. "Esc" is an abbreviation, much like "Ctrl" for "Control".

I think it is important to be consistent within the WordPress.
If "Escape" is a global standard, I think that is fine.

#4 in reply to: ↑ 2 @Hareesh Pillai
10 months ago

Replying to afercia:

I'd rather change all of them to "Escape" as that's the name of the key. "Esc" is an abbreviation, much like "Ctrl" for "Control".

While I agree that "Escape" is the actual name of the key, should we not use the convention that is present on the standard keyboard layout so that it is less confusing to the users?

Correct me if my understanding is wrong - When we say, press the "Control" key, users might find it difficult to understand as there is no "Control" key present on their keyboard. Using words like Esc and Ctrl in our communication is better, I think.

#5 @SergeyBiryukov
10 months ago

  • Milestone 5.3 deleted
  • Resolution set to duplicate
  • Status changed from reviewing to closed

Duplicate of #47036.

Note: See TracTickets for help on using tickets.