WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 21 months ago

#47319 closed defect (bug) (duplicate)

Automatic emails not triggering

Reported by: hurlburtgf Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2
Component: Site Health Keywords: servehappy reporter-feedback
Focuses: administration Cc:

Description

Have 5 page faults. Got an email on the first and was all to fix the php on 2 of the 5. Still getting three white screens, but no emails have followed since theorist successful one. Checked junk-mail to no avail

Change History (9)

#1 @SergeyBiryukov
2 years ago

  • Component changed from General to Bootstrap/Load
  • Focuses ui accessibility removed
  • Keywords servehappy added

This ticket was mentioned in Slack in #core-php by joyously. View the logs.


2 years ago

#3 @TimothyBlynJacobs
2 years ago

  • Keywords reporter-feedback added

Thank you for the report @hurlburtgf! How long had it been since the first email? The email won't send more than once every 24 hours.

#4 @desrosj
2 years ago

Also, recovery mode is not supported for must use plugins or drop-ins. Can you confirm the errors were in normal plugins?

#5 @hurlburtgf
2 years ago

I retried getting to one of the "bad pages" and got an email reply approximately an hour later. I m using the "PHP Code for Posts" plugin, and, as was the case on Friday, the error was pinpointed. The one delayed message per 24 hour period, however, does seem rather restrictive.
Thanks for the timely replies! Impressive!

#6 @spacedmonkey
2 years ago

Recovery mode is also not support if you running multisite.

#7 @hurlburtgf
2 years ago

I was finally able to fix all "bad" pages, but not without some great effort. The daily frequency of single messages was a real bottleneck. Worse, when I made code changes that were "acceptable" the pages could be edited. Problems arose the next days, however, as pages that "worked" once fixed, showed up as "bad" the following days. Worse, the code changes required by the WP code affected the intended php functions as originally encoded. I finally reverted all the php to its original state across the board and everything suddenly started to work once again as intended, I assured this through some significant testing. I guess, I must live with the inability to inspect pages and rely on a spreadsheet to know what the sequence of php snippets and related forms must be. Very disappointing.

#8 @spacedmonkey
2 years ago

  • Component changed from Bootstrap/Load to Site Health

#9 @TimothyBlynJacobs
21 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I'm sorry you experienced those troubles @hurlburtgf. We're exploring adding a way to request an email at any time by using your email address in #47192. I'm going to close this ticket out as I think landing that will solve the part of your issue that core can fix.

Note: See TracTickets for help on using tickets.