WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 14 months ago

#47343 closed defect (bug) (duplicate)

Message during update : authenticity could not be verified as no signature was found

Reported by: laserjobs Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.1
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

During the update to 5.2.1 got the following message in the control panel:
"The authenticity of wordpress-5.2.1-no-content.zip could not be verified as no signature was found."

The update was sucessful

Change History (7)

#1 @SergeyBiryukov
3 years ago

  • Component changed from General to Upgrade/Install

#2 @desrosj
3 years ago

Related: #45806, #39309.

#3 @garrett-eclipse
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

This message can be safely ignored. In WP 5.2 the package signature code was being implemented but needed to be rolled back due to some PHP incompatibilities. The messaging was left and can be ignored for now. In future the signature verification will be re-implemented.

#4 @garrett-eclipse
2 years ago

More definitive information on this;

Signature verification is not yet enabled, so this message is expected to be displayed.
[44954] introduced experimental package signature verification. However, there were some difficult problems identified that need to be solved in order to securely use this feature in practice. You can read more about this here https://make.wordpress.org/core/2019/08/16/ssl-for-auto-updates/.

Reference - https://core.trac.wordpress.org/ticket/49004#comment:4

#5 @SergeyBiryukov
2 years ago

#49004 was marked as a duplicate.

#7 @SergeyBiryukov
14 months ago

  • Resolution changed from invalid to duplicate

Duplicate of #47315.

Note: See TracTickets for help on using tickets.