WordPress.org

Make WordPress Core

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 3 weeks ago

#47391 closed defect (bug) (invalid)

AJAX Fails in 5.2.1. Update

Reported by: susanfla2 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Site Health Keywords: site-health
Focuses: Cc:

Description

Recent research on the Site Maintenance bug that issues AJAX failure and Loopback failure that disabling plugins only causes the Site Maintenance percentages to fail further i.e., 61% to 57% after re-enabling plugins which did not cause any issues. Since AJAX is essential to the core, an attempt was also made to enable legacy AJAX features due to the update. This did not resolve the AJAX failure either. Also, noticed that some features such as site statistics for sales are not working. AJAX is essential to transaction processing systems features as well as the core. Haven't seen issues in testing transactions in test mode, yet. What tests can be run using (Admin-Ajax.php) to determine missing functionality?

Change History (8)

#1 @SergeyBiryukov
7 weeks ago

  • Component changed from General to Administration
  • Keywords site-health added

#2 @desrosj
7 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Hi @susanfla2,

I'm afraid I'm not exactly sure what this is reporting. It seems that you are trying to fix a failed test you are seeing in the new Site Health tool. There are no tests in WordPress core that specifically mention AJAX, though.

For this, I recommend opening a ticket in the WordPress.org support forums, as this is better categorized as a support request.

You also mentioned an issue with your site statistics for sales. This is not something included in WordPress Core by default. You will need to reach out to the support team for whichever plugin you are using for that functionality.

#3 follow-up: @susanfla2
7 weeks ago

Ajax is part of the core of WordPress i.e., admin-ajax.php. Your latest update (which I haven't installed yet) attempts to resolve the issue for Site Health.

What I am seeing is several issues some of which existed prior to 5.2.1 update in the code but I can't locate the code anymore in the back-end to resolve the problem. For example the following code is related to an old theme which put random links in accordion of the customize panel:

<script type="text/javascript">
var ajaxurl = "\/wp-admin\/admin-ajax.php",
	pagenow = 'customize';
</script>

The code exists in the admin-ajax.php for pagenow but doesn't remove the links: see image. There is a series of this types of customization the old theme put into the admin on updates.

Last edited 7 weeks ago by SergeyBiryukov (previous) (diff)

#4 @susanfla2
7 weeks ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

#5 in reply to: ↑ 3 @desrosj
7 weeks ago

  • Keywords close added

Replying to susanfla2:

Your latest update (which I haven't installed yet) attempts to resolve the issue for Site Health.

I'm not sure what you mean. Have you tested the latest update and just have not installed it on your production server? Can you detail how you are sure it is broken in 5.2.1 if you have not updated yet?

What I am seeing is several issues some of which existed prior to 5.2.1 update in the code but I can't locate the code anymore in the back-end to resolve the problem.

Can you detail what those problems were? As far as I can tell, nothing was changed in 5.2.1 that affects AJAX calls. You can see a detailed list of changes in 5.2.1 here.

For example the following code is related to an old theme which put random links in accordion of the customize panel

The code snippet still is included in the page output when using the Customizer. I don't know what random links you are referring to. Which section of the Customizer?

Can you provide more specific details and maybe screenshots about what you are seeing, and detailed steps for someone to reproduce the issue? This still seems like a support request and not a problem with WordPress Core, though.

Last edited 7 weeks ago by desrosj (previous) (diff)

#6 @susanfla2
7 weeks ago

Desrosj:

I updated from t.2 to 5.2.1 and then determined what issues I had with the new Wordpress Core update. If the update doesn't work I roll backwards to determine the difference. That's how I can detail issues I see that are different.

As far as the next update for WordPress Core, you just released it this week. I updated to 5.2.1 last week. Your new update for WordPress Core 3.6.3 outlines the following fixes:

3.6.4 – 2019-05-27
Enhancement – Add notice to install WooCommerce Admin. #23659
Fix – Tracks: Add check for OBW is-opting-in. #23772
Fix – Use HTTP protocol for schema.org’s availability. #23774
Fix – Coupon usage limit checks based on email never ran when orders are created via wp-admin. #23775
Fix – Duplicate out of stock notices when navigating from cart to checkout and back to cart. #23791
Fix – Remove sensitive information from refund reason when manually refunding an order, and move it to an order note. #23739
Tweak – Tracks: set cookie on admin_init instead of wp_loaded. #23787
Dev – Fixed number of arguments for all occurrences of the woocommerce_valid_order_statuses_for_cancel filter. #23704
Dev – REST API – Stop order creation if invalid data is sent. #23325
Dev – Introduce new wc_load_cart function for dynamically loading and initializing the cart. #23794
3.6.3 – 2019-05-16
Fix – State not required for Serbia. #23430
Fix – # symbol in product category name broke product export. #23454
Fix – XML export caused fatal errors due to Action Scheduler adding invalid characters. #23456
Fix – Invalid password messages when password contains backslashes. #23499

yada, yada...

Don't worry about the accordian. It looks like its in the JS and I will figure it out eventually, hopefully without breaking it...

#7 @desrosj
7 weeks ago

  • Keywords close removed
  • Resolution set to invalid
  • Status changed from reopened to closed

This update list for 3.6.4 is for WooCommerce, not WordPress core. Please open a support ticket for your issue in their plugin support forums.

#8 @spacedmonkey
3 weeks ago

  • Component changed from Administration to Site Health
Note: See TracTickets for help on using tickets.