WordPress.org

Make WordPress Core

Opened 15 months ago

Closed 15 months ago

Last modified 15 months ago

#47403 closed defect (bug) (invalid)

Tweet with image(s) not rendered in frontend

Reported by: openstream Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.2.1
Component: Embeds Keywords:
Focuses: Cc:

Description

I wrote a blog post with multiple embedded tweets. The first one with image shows correctly, but the 2nd one doesn't. In the backend, though, all embedded tweets show properly. The tweet is https://twitter.com/nickweisser/status/869879894385328128, but I also tested with other tweets that only contain one image, same result. If I use a text-only tweet it's rendered correctly, though.

I'm going to test this with another theme shorty, to make sure it's not theme related...

Attachments (2)

Screenshot Frontend.png (84.2 KB) - added by openstream 15 months ago.
Screenshot Backend.png (438.8 KB) - added by openstream 15 months ago.

Download all attachments as: .zip

Change History (5)

#1 @openstream
15 months ago

  • Resolution set to invalid
  • Status changed from new to closed

It works with Twenty Nineteen, so it seems to be theme related 🙄

#2 @swissspidy
15 months ago

  • Component changed from General to Embeds
  • Milestone Awaiting Review deleted

FWIW when an oEmbed does not work it's often because of intermittent request failures. WordPress caches failed requests on a per-post basis. What usually helps is clearing that cache (e.g. using wp embed clear) or by creating a new post.

#3 @openstream
15 months ago

Thanks for the pointer, wp embed cache clear <post_id> fixed it 😱

Note: See TracTickets for help on using tickets.